summarylogtreecommitdiffstats
path: root/python_no_libs.patch
diff options
context:
space:
mode:
authorDmitry Popov2019-08-19 22:26:36 +0300
committerDmitry Popov2019-08-19 22:26:36 +0300
commited4c6fc192829a4659d558f3b7648b51f71fa50e (patch)
treeef565a2caf7d28e6626b1ca42809c447a9b4050b /python_no_libs.patch
parent3afc6f59af6e249bf2b1bdec88922cfea20b4695 (diff)
downloadaur-ed4c6fc192829a4659d558f3b7648b51f71fa50e.tar.gz
Bump version (to r3854.97007765) and fix patches accordingly
Diffstat (limited to 'python_no_libs.patch')
-rw-r--r--python_no_libs.patch12
1 files changed, 6 insertions, 6 deletions
diff --git a/python_no_libs.patch b/python_no_libs.patch
index 38d778498bf6..15a95ac7ad1c 100644
--- a/python_no_libs.patch
+++ b/python_no_libs.patch
@@ -1,8 +1,8 @@
diff --git a/python-package/setup.py b/python-package/setup.py
-index 30e0d070..f96ef69e 100644
+index a2146f6b..7f13a07b 100644
--- a/python-package/setup.py
+++ b/python-package/setup.py
-@@ -8,28 +8,9 @@ import os
+@@ -7,28 +7,9 @@ import os
from setuptools import setup, find_packages
# import subprocess
@@ -28,10 +28,10 @@ index 30e0d070..f96ef69e 100644
-
-print("Install libxgboost from: %s" % LIB_PATH)
-
- # Get dmlc tracker script
- shutil.copy('../dmlc-core/tracker/dmlc_tracker/tracker.py', 'xgboost/')
-
-@@ -50,7 +31,6 @@ setup(name='xgboost',
+ # Please use setup_pip.py for generating and deploying pip installation
+ # detailed instruction in setup_pip.py
+ setup(name='xgboost',
+@@ -53,7 +34,6 @@ setup(name='xgboost',
# this will use MANIFEST.in during install where we specify additional files,
# this is the golden line
include_package_data=True,