summarylogtreecommitdiffstats
path: root/pyxdg-compatibility.patch
diff options
context:
space:
mode:
authorMike Javorski2023-02-23 14:28:34 -0800
committerMike Javorski2023-02-23 14:28:34 -0800
commitdecd830308e31d76abdca770393e865dbe727deb (patch)
treefc775de6dfc7ae52cb53dee6b8367971a2c03031 /pyxdg-compatibility.patch
parent69024913bbb37d0d8db8c2837f9e6f2ef693865e (diff)
downloadaur-dput.tar.gz
Update to latest release 1.1.3
Diffstat (limited to 'pyxdg-compatibility.patch')
-rw-r--r--pyxdg-compatibility.patch14
1 files changed, 7 insertions, 7 deletions
diff --git a/pyxdg-compatibility.patch b/pyxdg-compatibility.patch
index d64f96bea5be..ccce6334ffd6 100644
--- a/pyxdg-compatibility.patch
+++ b/pyxdg-compatibility.patch
@@ -8,13 +8,13 @@ diff -rU2 dput.orig/dput/configfile.py dput/dput/configfile.py
+from xdg import BaseDirectory
-@@ -44,5 +44,5 @@
- ('global', os.path.join(os.path.sep, 'etc', 'dput.cf')),
- ('user_xdg', os.path.join(
-- xdg.xdg_config_home(), 'dput', 'dput.cf')),
-+ BaseDirectory.xdg_config_home, 'dput', 'dput.cf')),
- ('user_home', os.path.join(
- os.path.expanduser('~'), '.dput.cf')),
+@@ -23,5 +23,5 @@
+ ('global', os.path.join(os.path.sep, "etc", "dput.cf")),
+ ('user_xdg', os.path.join(
+- xdg.xdg_config_home(), "dput", "dput.cf")),
++ BaseDirectory.xdg_config_home, 'dput', 'dput.cf')),
+ ('user_home', os.path.join(
+ os.path.expanduser("~"), ".dput.cf")),
diff -rU2 dput.orig/setup.py dput/setup.py
--- dput.orig/setup.py 2022-07-01 15:15:28.000000000 -0700
+++ dput/setup.py 2022-10-27 10:36:34.862581758 -0700