summarylogtreecommitdiffstats
path: root/qemu.install
diff options
context:
space:
mode:
authorajs1242015-08-07 15:58:34 +0200
committerajs1242015-08-07 15:59:57 +0200
commit98e46f9cbfd0ae48ec46576a56abed21b3c5ab81 (patch)
treec874db7f03023078fca636f62173a7c96f080e16 /qemu.install
parentf175096d9f91db6dc96cba58e5786c51f1e99dbe (diff)
downloadaur-98e46f9cbfd0ae48ec46576a56abed21b3c5ab81.tar.gz
Remodel PKGBUILD and surrounding files after [extra] package
- split package - disabled spice for now, since it doesn't compile for some reason
Diffstat (limited to 'qemu.install')
-rw-r--r--qemu.install24
1 files changed, 11 insertions, 13 deletions
diff --git a/qemu.install b/qemu.install
index 7a384814cb3b..be5b0184ad2f 100644
--- a/qemu.install
+++ b/qemu.install
@@ -1,26 +1,24 @@
-# kvm: the new package version
+# Arg 1: the new package version
post_install() {
- #
- groupadd kvm -f -g 78
- echo "As of revision 31714, there is no need to add -bios /usr/share/qemu/bios.bin"
- echo "anymore to your qemu command line"
+ # create kvm group
+ systemd-sysusers qemu.conf
+
+ # retrigger events on modules files when already loaded
+ [[ -e /dev/kvm ]] && udevadm trigger /dev/kvm
+ [[ -e /dev/vhost-net ]] && udevadm trigger /dev/vhost-net
}
+# arg 1: the new package version
+# arg 2: the old package version
post_upgrade() {
- if [ "$(vercmp $2 0.11)" -lt 0 ]; then
+ if (( "$(vercmp $2 0.11)" < 0 )); then
echo "With the release of qemu and qemu-kvm 0.12.X, the kqemu kernel module"
echo "is no longer supported and will be removed from the repositories. You"
echo "can safely uninstall it from your system."
fi
- if [ "$(vercmp $2 1.3.1)" -lt 0 ]; then
+ if (( "$(vercmp $2 1.3.1)" < 0 )); then
echo "With the release of qemu 1.3.0, qemu-kvm binary is removed."
echo "You need to change the emulator path, if you use libvirt by using:"
echo "'virsh edit <vm-name>'"
fi
}
-
-post_remove() {
- #
- groupdel kvm
-}
-