summarylogtreecommitdiffstats
path: root/qt4-gcc6.patch
diff options
context:
space:
mode:
authorLlewelyn Trahaearn2017-02-18 11:23:49 -0800
committerLlewelyn Trahaearn2017-02-18 11:23:49 -0800
commitbef4f7fb2f5bbbeb5da6959c5757cd108db51996 (patch)
treeb4778f34e36bce66c7afa554243f3c806be13063 /qt4-gcc6.patch
parent77e07c49a2e24c4d64fa1b25fb54c123a7367136 (diff)
downloadaur-bef4f7fb2f5bbbeb5da6959c5757cd108db51996.tar.gz
Adopted, rebased on PKGBUILD from [Extra]. Clang no longer used.
Diffstat (limited to 'qt4-gcc6.patch')
-rw-r--r--qt4-gcc6.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/qt4-gcc6.patch b/qt4-gcc6.patch
new file mode 100644
index 000000000000..d65cd2463c0c
--- /dev/null
+++ b/qt4-gcc6.patch
@@ -0,0 +1,36 @@
+diff -up qt-everywhere-opensource-src-4.8.7/configure.gcc6 qt-everywhere-opensource-src-4.8.7/configure
+--- qt-everywhere-opensource-src-4.8.7/configure.gcc6 2016-04-15 07:04:19.430268222 -0500
++++ qt-everywhere-opensource-src-4.8.7/configure 2016-04-15 07:05:22.157568689 -0500
+@@ -7744,7 +7744,7 @@ case "$XPLATFORM" in
+ *-g++*)
+ # Check gcc's version
+ case "$(${QMAKE_CONF_COMPILER} -dumpversion)" in
+- 5*|4*|3.4*)
++ 8*|7*|6*|5*|4*|3.4*)
+ ;;
+ 3.3*)
+ canBuildWebKit="no"
+@@ -8060,7 +8060,7 @@ g++*)
+ 3.*)
+ COMPILER_VERSION="3.*"
+ ;;
+- 5*|4.*)
++ 8*|7*|6*|5*|4.*)
+ COMPILER_VERSION="4"
+ ;;
+ *)
+diff -up qt-everywhere-opensource-src-4.8.7/src/xmlpatterns/api/qcoloroutput_p.h.gcc6
+qt-everywhere-opensource-src-4.8.7/src/xmlpatterns/api/qcoloroutput_p.h
+--- qt-everywhere-opensource-src-4.8.7/src/xmlpatterns/api/qcoloroutput_p.h.gcc6 2015-05-07 09:14:48.000000000 -0500
++++ qt-everywhere-opensource-src-4.8.7/src/xmlpatterns/api/qcoloroutput_p.h 2016-04-15 07:04:19.431268227 -0500
+@@ -70,8 +70,8 @@ namespace QPatternist
+ ForegroundShift = 10,
+ BackgroundShift = 20,
+ SpecialShift = 20,
+- ForegroundMask = ((1 << ForegroundShift) - 1) << ForegroundShift,
+- BackgroundMask = ((1 << BackgroundShift) - 1) << BackgroundShift
++ ForegroundMask = 0x1f << ForegroundShift,
++ BackgroundMask = 0x7 << BackgroundShift
+ };
+
+ public: