summarylogtreecommitdiffstats
path: root/qt5-qt4-coexist.patch
diff options
context:
space:
mode:
authorponsfoot2017-10-03 19:48:01 +0900
committerponsfoot2017-10-03 19:48:01 +0900
commit7894918ecb46b75b190bb1af64750243828c710e (patch)
tree2f0b9c43f728d7030f99e26ad4b299cf0a487618 /qt5-qt4-coexist.patch
parent0a224f90173bea4d934a80bf7ff51f1fbe146dd4 (diff)
downloadaur-7894918ecb46b75b190bb1af64750243828c710e.tar.gz
Upstream update: 1.8.6+gh20161003.0.d63dadd-5
Diffstat (limited to 'qt5-qt4-coexist.patch')
-rw-r--r--qt5-qt4-coexist.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/qt5-qt4-coexist.patch b/qt5-qt4-coexist.patch
new file mode 100644
index 000000000000..2a352c6745af
--- /dev/null
+++ b/qt5-qt4-coexist.patch
@@ -0,0 +1,17 @@
+Description: fix CMake Error not found QT_QT_INCLUDE_DIR when specify both --with-qt4 and --with-qt5.
+Author: HIGUCHI Daisuke (VDR dai) <dai@debian.org>
+Forwarded: https://github.com/uim/uim/pull/62
+Last-Update: 2015-07-22
+
+diff --git a/qt4/toolbar/CMakeLists.txt b/qt4/toolbar/CMakeLists.txt
+index 4601afb..45bc23c 100644
+--- a/qt4/toolbar/CMakeLists.txt
++++ b/qt4/toolbar/CMakeLists.txt
+@@ -1,6 +1,7 @@
+ project(plasma-uim)
+ set(CMAKE_VERBOSE_MAKEFILE on)
+
++find_package(Qt4)
+ find_package(KDE4 REQUIRED)
+ include(KDE4Defaults)
+