summarylogtreecommitdiffstats
path: root/redis-2.8.11-use-system-jemalloc.patch
diff options
context:
space:
mode:
authorLeo P2016-04-05 01:13:58 -0400
committerLeo P2016-04-05 01:13:58 -0400
commitf1a6118a225268149a82fde1c64abdf23899f580 (patch)
tree18d245fc24aadef0b746c11a0820b2d7b00dcc89 /redis-2.8.11-use-system-jemalloc.patch
downloadaur-redis-testing.tar.gz
first
Diffstat (limited to 'redis-2.8.11-use-system-jemalloc.patch')
-rw-r--r--redis-2.8.11-use-system-jemalloc.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/redis-2.8.11-use-system-jemalloc.patch b/redis-2.8.11-use-system-jemalloc.patch
new file mode 100644
index 000000000000..5da3d6816fe3
--- /dev/null
+++ b/redis-2.8.11-use-system-jemalloc.patch
@@ -0,0 +1,15 @@
+Index: redis-2.8.11/src/Makefile
+===================================================================
+--- redis-2.8.11.orig/src/Makefile
++++ redis-2.8.11/src/Makefile
+@@ -84,8 +84,8 @@ endif
+
+ ifeq ($(MALLOC),jemalloc)
+ DEPENDENCY_TARGETS+= jemalloc
+- FINAL_CFLAGS+= -DUSE_JEMALLOC -I../deps/jemalloc/include
+- FINAL_LIBS+= ../deps/jemalloc/lib/libjemalloc.a -ldl
++ FINAL_CFLAGS+= -DUSE_JEMALLOC -DJEMALLOC_NO_DEMANGLE -I/usr/include/jemalloc
++ FINAL_LIBS+= -ljemalloc -ldl
+ endif
+
+ REDIS_CC=$(QUIET_CC)$(CC) $(FINAL_CFLAGS)