summarylogtreecommitdiffstats
path: root/reproducible_build.patch
diff options
context:
space:
mode:
authoranthraxx2016-11-13 16:35:29 +0100
committeranthraxx2016-11-13 16:35:29 +0100
commit643c68c2e7997e30b791c71f489eca481bd0280f (patch)
treef54b727c1180840ba92f109fa01ac627d0df6871 /reproducible_build.patch
parent1a0503380c5a232a86caed090b0296463b4ce324 (diff)
downloadaur-xprobe2.tar.gz
upgpkg: xprobe2 0.3-3
Diffstat (limited to 'reproducible_build.patch')
-rw-r--r--reproducible_build.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/reproducible_build.patch b/reproducible_build.patch
new file mode 100644
index 000000000000..fa353a085322
--- /dev/null
+++ b/reproducible_build.patch
@@ -0,0 +1,49 @@
+Author: Reiner Herrmann <reiner@reiner-h.de>
+Description: Sort order of object files in static libraries
+
+--- a/libs-external/USI++/src/Makefile.in
++++ b/libs-external/USI++/src/Makefile.in
+@@ -15,7 +15,7 @@
+ clear
+
+ usi++:icmp.o datalink.o ip.o misc.o udp.o tcp.o TX_IP.o Layer2.o arp.o
+- ar cr libusi++.a *.o
++ ar cr libusi++.a `LC_ALL=C ls *.o`
+ # ld *.o -Bshareable -o libusi++.so
+ $(RANLIB) libusi++.a
+ rm -f *.o
+--- a/src/xpmodules/alive_probe/Makefile.in
++++ b/src/xpmodules/alive_probe/Makefile.in
+@@ -42,7 +42,7 @@
+ all: alive_probe.a
+
+ alive_probe.a: icmp_ping.o tcp_ping.o udp_ping.o ttl_module portscan_module
+- ar cr alive_probe.a *.o ttl_calc/*.o portscanner/*.o
++ ar cr alive_probe.a `LC_ALL=C ls *.o ttl_calc/*.o portscanner/*.o`
+ $(RANLIB) alive_probe.a
+
+ icmp_ping.o: icmp_ping.cc
+--- a/src/xpmodules/os_probe/Makefile.in
++++ b/src/xpmodules/os_probe/Makefile.in
+@@ -43,8 +43,8 @@
+
+ os_probe.a: icmp_port_unreach_mod icmp_echo_id_mod icmp_timestamp_mod \
+ icmp_inforeq_mod icmp_addrmask_mod tcp_handshake_mod tcp_rst_mod smb_mod snmp_mod
+- ar cr os_probe.a icmp_port_unreach/*.o icmp_echo_id/*.o icmp_timestamp/*.o \
+- icmp_inforeq/*.o icmp_addrmask/*.o tcp_handshake/*.o tcp_rst/*.o smb/*.o snmp/*.o
++ ar cr os_probe.a `LC_ALL=C ls icmp_port_unreach/*.o icmp_echo_id/*.o icmp_timestamp/*.o \
++ icmp_inforeq/*.o icmp_addrmask/*.o tcp_handshake/*.o tcp_rst/*.o smb/*.o snmp/*.o`
+ $(RANLIB) os_probe.a
+
+
+--- a/src/xplib/Makefile.in
++++ b/src/xplib/Makefile.in
+@@ -44,7 +44,7 @@
+ all: libxplib.a
+
+ libxplib.a: $(OBJS)
+- ar cr libxplib.a *.o
++ ar cr libxplib.a `LC_ALL=C ls *.o`
+ $(RANLIB) libxplib.a
+
+ .c.o: $(INCLUDES)