summarylogtreecommitdiffstats
path: root/requirements.patch
diff options
context:
space:
mode:
authorS Garnica2020-03-26 19:10:06 +0100
committerS Garnica2020-03-26 19:10:06 +0100
commit2ac874280671cc8c54439c1e1bd09ebf433999fb (patch)
treeafb537a955affd4d11fdc7c3377ed3b703e2e4b5 /requirements.patch
parentbc9b785dd3450de181c256ac423f38bb9525e27d (diff)
downloadaur-2ac874280671cc8c54439c1e1bd09ebf433999fb.tar.gz
Updated requirements
Diffstat (limited to 'requirements.patch')
-rw-r--r--requirements.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/requirements.patch b/requirements.patch
new file mode 100644
index 000000000000..cad2e45d8390
--- /dev/null
+++ b/requirements.patch
@@ -0,0 +1,42 @@
+diff --unified --recursive --text package.orig/setup.py package.new/setup.py
+--- package.orig/setup.py 2019-11-17 23:37:00.000000000 +0100
++++ package.new/setup.py 2020-03-25 10:35:51.286114759 +0100
+@@ -23,17 +23,17 @@
+ DOWNLOAD_URL = '{}/archive/v{}.zip'.format(GITHUB_URL, const.__version__)
+
+ REQUIRES = [
+- 'voluptuous==0.11.7',
+- 'PyYAML==5.1.2',
+- 'paho-mqtt==1.4.0',
+- 'colorlog==4.0.2',
+- 'tornado==5.1.1',
++ 'voluptuous',
++ 'PyYAML',
++ 'paho-mqtt',
++ 'colorlog',
++ 'tornado',
+ 'typing>=3.6.6;python_version<"3.6"',
+- 'protobuf==3.10.0',
+- 'tzlocal==2.0.0',
+- 'pytz==2019.3',
+- 'pyserial==3.4',
+- 'ifaddr==0.1.6',
++ 'protobuf',
++ 'tzlocal',
++ 'pytz',
++ 'pyserial',
++ 'ifaddr',
+ ]
+
+ # If you have problems importing platformio and esptool as modules you can set
+@@ -41,8 +41,8 @@
+ # This means they have to be in your $PATH.
+ if os.environ.get('ESPHOME_USE_SUBPROCESS') is None:
+ REQUIRES.extend([
+- 'platformio==4.0.3',
+- 'esptool==2.7',
++ 'platformio',
++ 'esptool',
+ ])
+
+ CLASSIFIERS = [