summarylogtreecommitdiffstats
path: root/requirements.patch
diff options
context:
space:
mode:
authorMatthew Gamble2017-04-13 09:18:10 +1000
committerMatthew Gamble2017-04-13 09:18:10 +1000
commit99251075b96d4c485a688f842a28689b639e3270 (patch)
tree2ab03625d252a28421c6b4b14f255229320ad3a2 /requirements.patch
downloadaur-99251075b96d4c485a688f842a28689b639e3270.tar.gz
Initial commit
Diffstat (limited to 'requirements.patch')
-rw-r--r--requirements.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/requirements.patch b/requirements.patch
new file mode 100644
index 000000000000..546dd2cc886d
--- /dev/null
+++ b/requirements.patch
@@ -0,0 +1,18 @@
+From: Matthew Gamble <git@matthewgamble.net>
+
+pyforge is incorrectly listed as a hard requirement in setup.py, when in fact
+it's actually just for running the test suite for this library.
+
+diff --git a/setup.py b/setup.py
+index 9601262..62ec31f 100644
+--- a/setup.py
++++ b/setup.py
+@@ -25,7 +25,7 @@ setup(name="infi.unittest",
+ version=__version__,
+ packages=find_packages(exclude=["tests"]),
+ namespace_packages=["infi"],
+- install_requires=_REQUIREMENTS,
++ install_requires=["munch"],
+ scripts=[],
+ entry_points = {
+ 'nose.plugins.0.10': [