summarylogtreecommitdiffstats
path: root/rocm-opencl-runtime-2.8.0-amdocl64icd.patch
diff options
context:
space:
mode:
authorRanieri Althoff2020-01-30 14:58:38 -0300
committerRanieri Althoff2020-01-30 15:00:42 -0300
commit3595582a0882d75e7153c12e8464499bfd5e2e27 (patch)
tree783d13eb39566251f39a496f2278854a4346b5d7 /rocm-opencl-runtime-2.8.0-amdocl64icd.patch
parentf65dd3f6e16f73461c4944d15a55bcb3a41dd9e9 (diff)
downloadaur-3595582a0882d75e7153c12e8464499bfd5e2e27.tar.gz
v3.0.0-2
- Split llvm and comgr packages - Fix build artifacts
Diffstat (limited to 'rocm-opencl-runtime-2.8.0-amdocl64icd.patch')
-rw-r--r--rocm-opencl-runtime-2.8.0-amdocl64icd.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/rocm-opencl-runtime-2.8.0-amdocl64icd.patch b/rocm-opencl-runtime-2.8.0-amdocl64icd.patch
new file mode 100644
index 000000000000..f399f360c9cf
--- /dev/null
+++ b/rocm-opencl-runtime-2.8.0-amdocl64icd.patch
@@ -0,0 +1,13 @@
+diff --git a/api/opencl/amdocl/CMakeLists.txt b/api/opencl/amdocl/CMakeLists.txt
+index 8ea8517..d1223ed 100644
+--- a/api/opencl/amdocl/CMakeLists.txt
++++ b/api/opencl/amdocl/CMakeLists.txt
+@@ -82,3 +82,7 @@ if(${USE_COMGR_LIBRARY} MATCHES "yes")
+ else()
+ target_link_libraries(amdocl64 opencl_driver oclelf pthread dl ${ROCT_LIBRARIES} ${ROCR_LIBRARIES})
+ endif()
++
++file(GENERATE OUTPUT "${CMAKE_BINARY_DIR}/amdocl64.icd" CONTENT "$<TARGET_FILE_NAME:amdocl64>")
++install(FILES "${CMAKE_BINARY_DIR}/amdocl64.icd" DESTINATION "${CMAKE_INSTALL_FULL_SYSCONFDIR}/OpenCL/vendors/")
++
+