summarylogtreecommitdiffstats
path: root/root-src-fix.patch
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-28 20:17:14 +0100
committerJaroslav Lichtblau2014-11-28 20:17:14 +0100
commit47b47d47bb5f7555b796a9ab4feb6924a7a9d946 (patch)
tree7e812bd3b4c4c8360bad245076f84fd6af566b8c /root-src-fix.patch
downloadaur-47b47d47bb5f7555b796a9ab4feb6924a7a9d946.tar.gz
Initial PKGBUILD status as of 28.11.2014
Diffstat (limited to 'root-src-fix.patch')
-rw-r--r--root-src-fix.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/root-src-fix.patch b/root-src-fix.patch
new file mode 100644
index 000000000000..a822ef61f029
--- /dev/null
+++ b/root-src-fix.patch
@@ -0,0 +1,22 @@
+--- lb.py~ 2008-05-13 22:56:36.000000000 -0400
++++ lb.py 2008-05-13 22:56:55.000000000 -0400
+@@ -281,6 +281,8 @@
+ """
+ def __init__(self, path):
+ self.path = os.path.abspath(path)
++ if self.path == os.sep:
++ self.path = ""
+ self.lenbase = len('%s%s' % (self.path, os.sep))
+ self.logpath = join(self.path, 'log')
+ if not os.path.exists(self.path):
+@@ -751,7 +753,9 @@
+ def build_filelist_from_tree(treepath):
+ class ListBuilder:
+ def __init__(self, basepath):
+- self.lenbase = len('%s%s' % (basepath, os.sep))
++ if basepath == os.sep:
++ basepath = ""
++ self.lenbase = len('%s%s' % (basepath, os.sep))
+
+ def callback(self, arg, dirpath, filelist):
+ for file in filelist: