summarylogtreecommitdiffstats
path: root/sagemath-bliss-0.77.patch
diff options
context:
space:
mode:
authorAntonio Rojas2022-02-28 20:48:43 +0100
committerAntonio Rojas2022-02-28 20:48:43 +0100
commit2e52ff35bfa0d5cc76ff19580fd9d6e4d7253a97 (patch)
tree40cb764772521b3086872d985db15cb0721a9a45 /sagemath-bliss-0.77.patch
parent210622d5c0b61b7b076e647d979faddf8b11fb28 (diff)
downloadaur-2e52ff35bfa0d5cc76ff19580fd9d6e4d7253a97.tar.gz
Rebase patches
Diffstat (limited to 'sagemath-bliss-0.77.patch')
-rw-r--r--sagemath-bliss-0.77.patch96
1 files changed, 79 insertions, 17 deletions
diff --git a/sagemath-bliss-0.77.patch b/sagemath-bliss-0.77.patch
index 2c0f11b56b81..4f95bcedf635 100644
--- a/sagemath-bliss-0.77.patch
+++ b/sagemath-bliss-0.77.patch
@@ -1,3 +1,34 @@
+diff --git a/build/pkgs/bliss/SPKG.rst b/build/pkgs/bliss/SPKG.rst
+index 236b87a199..77407f16ac 100644
+--- a/build/pkgs/bliss/SPKG.rst
++++ b/build/pkgs/bliss/SPKG.rst
+@@ -10,20 +10,19 @@ canonical forms of graphs.
+ License
+ -------
+
+-LGPL
++LGPL3
+
+
+ Upstream Contact
+ ----------------
+
+-Bliss is currently being maintained by Tommi Junttila and Petteri Kaski.
++Bliss is currently being maintained by Tommi Junttila at
+
+-http://www.tcs.tkk.fi/Software/bliss/index.html
++https://users.aalto.fi/~tjunttil/bliss/index.html
++
++Bliss used to be maintained by Tommi Junttila and Petteri Kaski up to version 0.73 at
+
+-We apply patches generated from https://github.com/mkoeppe/bliss (branch
+-apply_debian_patches) as our upstream. This tracks the patches from the
+-Debian package, adding an autotools build system and adjusting the
+-include file locations.
++http://www.tcs.tkk.fi/Software/bliss/index.html
+
+ Dependencies
+ ------------
diff --git a/build/pkgs/bliss/checksums.ini b/build/pkgs/bliss/checksums.ini
index e97d89587b..0c1ebf647b 100644
--- a/build/pkgs/bliss/checksums.ini
@@ -29,19 +60,54 @@ index e93ee1376f..9e1e206c41 100644
@@ -1 +1 @@
-0.73+debian-1+sage-2016-08-02.p0
+0.77
+diff --git a/build/pkgs/bliss/patches/bliss-0.77-install.patch b/build/pkgs/bliss/patches/bliss-0.77-install.patch
+new file mode 100644
+index 0000000000..caab14aa40
+--- /dev/null
++++ b/build/pkgs/bliss/patches/bliss-0.77-install.patch
+@@ -0,0 +1,32 @@
++diff --git a/CMakeLists.txt b/CMakeLists.txt
++index 01ed093..cfdb0a6 100644
++--- a/CMakeLists.txt
+++++ b/CMakeLists.txt
++@@ -62,3 +62,27 @@ if(USE_GMP)
++ target_link_libraries(bliss-executable ${GMP_LIBRARIES})
++ endif(USE_GMP)
++ set_target_properties(bliss-executable PROPERTIES OUTPUT_NAME bliss)
+++
+++include(GNUInstallDirs)
+++
+++set(
+++ BLISS_HEADERS
+++ src/bliss_C.h
+++ src/uintseqhash.hh
+++ src/abstractgraph.hh
+++ src/stats.hh
+++ src/digraph.hh
+++ src/defs.hh
+++ src/heap.hh
+++ src/graph.hh
+++ src/partition.hh
+++ src/kqueue.hh
+++ src/utils.hh
+++ src/orbit.hh
+++ src/timer.hh
+++ src/bignum.hh
+++)
+++
+++install(TARGETS bliss-executable RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
+++install(TARGETS bliss LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
+++install(FILES ${BLISS_HEADERS} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/bliss)
diff --git a/build/pkgs/bliss/spkg-install.in b/build/pkgs/bliss/spkg-install.in
-index aaf4c3037b..ad1fe8176c 100644
+index aaf4c3037b..4124a2338e 100644
--- a/build/pkgs/bliss/spkg-install.in
+++ b/build/pkgs/bliss/spkg-install.in
-@@ -1,4 +1,6 @@
+@@ -1,4 +1,4 @@
cd src
-sdh_configure --disable-gmp
+sdh_cmake -DUSE_GMP=OFF -DCMAKE_VERBOSE_MAKEFILE=ON
sdh_make
--sdh_make_install
-+sdh_install src/*.hh $SAGE_LOCAL/include/bliss/
-+sdh_install libbliss.so $SAGE_LOCAL/lib/
-+sdh_install bliss $SAGE_LOCAL/bin/
+ sdh_make_install
diff --git a/build/pkgs/bliss/spkg-src b/build/pkgs/bliss/spkg-src
deleted file mode 100755
index 90073233b7..0000000000
@@ -77,18 +143,16 @@ index 90073233b7..0000000000
-
-
diff --git a/src/sage/graphs/bliss.pyx b/src/sage/graphs/bliss.pyx
-index 22e861a587..fa426e3d11 100644
+index bf15833664..4f4e0ee3ca 100644
--- a/src/sage/graphs/bliss.pyx
+++ b/src/sage/graphs/bliss.pyx
-@@ -47,22 +47,27 @@ cdef extern from "bliss/graph.hh" namespace "bliss":
+@@ -47,22 +47,23 @@ cdef extern from "bliss/graph.hh" namespace "bliss":
cdef cppclass Graph(AbstractGraph):
Graph(const unsigned int)
void add_edge(const unsigned int, const unsigned int)
- void find_automorphisms(Stats&, void (*)(void* , unsigned int,
- const unsigned int*), void*)
-+ #void find_automorphisms(Stats&, void (*)(void* , unsigned int,
-+ #const unsigned int*), void*)
- void change_color(const unsigned int, const unsigned int);
+ void change_color(const unsigned int, const unsigned int)
- const unsigned int* canonical_form(Stats&, void (*)(void*,unsigned int,
- const unsigned int*), void*)
+ const unsigned int* canonical_form(Stats&)
@@ -100,9 +164,7 @@ index 22e861a587..fa426e3d11 100644
void add_edge(const unsigned int, const unsigned int)
- void find_automorphisms(Stats&, void (*)(void* , unsigned int,
- const unsigned int*), void*)
-+ #void find_automorphisms(Stats&, void (*)(void* , unsigned int,
-+ #const unsigned int*), void*)
- void change_color(const unsigned int, const unsigned int);
+ void change_color(const unsigned int, const unsigned int)
- const unsigned int* canonical_form(Stats&, void (*)(void*,unsigned int,
- const unsigned int*), void*)
+ const unsigned int* canonical_form(Stats&)
@@ -116,7 +178,7 @@ index 22e861a587..fa426e3d11 100644
cdef int encoding_numbits(int n):
r"""
-@@ -124,9 +129,6 @@ cdef void add_gen(void *user_param, unsigned int n, const unsigned int *aut):
+@@ -124,9 +125,6 @@ cdef void add_gen(void *user_param, unsigned int n, const unsigned int *aut):
sig_free(done)
@@ -126,7 +188,7 @@ index 22e861a587..fa426e3d11 100644
#####################################################
# constructing bliss graphs from edge lists
#####################################################
-@@ -345,10 +347,10 @@ cdef canonical_form_from_edge_list(int Vnr, list Vout, list Vin, int Lnr=1, list
+@@ -345,10 +343,10 @@ cdef canonical_form_from_edge_list(int Vnr, list Vout, list Vin, int Lnr=1, list
if directed:
d = bliss_digraph_from_labelled_edges(Vnr, Lnr, Vout, Vin, labels, partition)
@@ -139,7 +201,7 @@ index 22e861a587..fa426e3d11 100644
for i in range(len(Vout)):
x = Vout[i]
-@@ -640,11 +642,11 @@ cdef automorphism_group_gens_from_edge_list(int Vnr, Vout, Vin, int Lnr=1, label
+@@ -640,11 +638,11 @@ cdef automorphism_group_gens_from_edge_list(int Vnr, Vout, Vin, int Lnr=1, label
if directed:
d = bliss_digraph_from_labelled_edges(Vnr, Lnr, Vout, Vin, labels, partition)