summarylogtreecommitdiffstats
path: root/sagemath-python-3.8.patch
diff options
context:
space:
mode:
authorAntonio Rojas2020-03-02 08:36:59 +0000
committerAntonio Rojas2020-03-02 08:36:59 +0000
commitfe13c15dd6e85484b5fa732d6fb0fc128a68dedd (patch)
tree63aa0b14f99b69d2bbee26e5152592fdf4188df7 /sagemath-python-3.8.patch
parent1719741f4dfdce4d4fd18f10ea3050a7f6d9db99 (diff)
downloadaur-fe13c15dd6e85484b5fa732d6fb0fc128a68dedd.tar.gz
ext code is installed by setup.py now
Diffstat (limited to 'sagemath-python-3.8.patch')
-rw-r--r--sagemath-python-3.8.patch24
1 files changed, 12 insertions, 12 deletions
diff --git a/sagemath-python-3.8.patch b/sagemath-python-3.8.patch
index 5df00b5727b5..aee6689be4c4 100644
--- a/sagemath-python-3.8.patch
+++ b/sagemath-python-3.8.patch
@@ -378,7 +378,7 @@ diff --git a/src/sage/dynamics/arithmetic_dynamics/projective_ds.py b/src/sage/d
index 99ad85b695..4d2642366a 100644
--- a/src/sage/dynamics/arithmetic_dynamics/projective_ds.py
+++ b/src/sage/dynamics/arithmetic_dynamics/projective_ds.py
-@@ -3145,8 +3145,8 @@ class DynamicalSystem_projective(SchemeMorphism_polynomial_projective_space,
+@@ -3146,8 +3146,8 @@ class DynamicalSystem_projective(SchemeMorphism_polynomial_projective_space,
sage: D6 = DynamicalSystem_projective([y^2,x^2])
sage: D6.automorphism_group()
[
@@ -389,7 +389,7 @@ index 99ad85b695..4d2642366a 100644
]
"""
alg = kwds.get('algorithm', None)
-@@ -3670,13 +3670,13 @@ class DynamicalSystem_projective(SchemeMorphism_polynomial_projective_space,
+@@ -3671,13 +3671,13 @@ class DynamicalSystem_projective(SchemeMorphism_polynomial_projective_space,
sage: P.<x,y,z> = ProjectiveSpace(K,2)
sage: f = DynamicalSystem_projective([x^2+z^2, y^2+x^2, z^2+y^2])
sage: f.preperiodic_points(0,1)
@@ -410,7 +410,7 @@ index 99ad85b695..4d2642366a 100644
::
-@@ -3891,13 +3891,13 @@ class DynamicalSystem_projective(SchemeMorphism_polynomial_projective_space,
+@@ -3892,13 +3892,13 @@ class DynamicalSystem_projective(SchemeMorphism_polynomial_projective_space,
sage: P.<x,y,z> = ProjectiveSpace(K,2)
sage: f = DynamicalSystem_projective([x^2+z^2, y^2+x^2, z^2+y^2])
sage: f.periodic_points(1)
@@ -429,7 +429,7 @@ index 99ad85b695..4d2642366a 100644
::
-@@ -5494,7 +5494,7 @@ class DynamicalSystem_projective_field(DynamicalSystem_projective,
+@@ -5496,7 +5496,7 @@ class DynamicalSystem_projective_field(DynamicalSystem_projective,
sage: f.rational_periodic_points()
doctest:warning
...
@@ -438,7 +438,7 @@ index 99ad85b695..4d2642366a 100644
"""
from sage.misc.superseded import deprecation
deprecation(28109, "use sage.dynamics.arithmetic_dynamics.projective_ds.all_periodic_points instead")
-@@ -5938,8 +5938,8 @@ class DynamicalSystem_projective_field(DynamicalSystem_projective,
+@@ -5940,8 +5940,8 @@ class DynamicalSystem_projective_field(DynamicalSystem_projective,
(w^2 + w - 25/16 : 1),
(-w : 1),
(-w^2 + 29/16 : 1),
@@ -448,7 +448,7 @@ index 99ad85b695..4d2642366a 100644
(-w^2 + 21/16 : 1),
(w^2 - 21/16 : 1),
(w^2 + w - 33/16 : 1),
-@@ -6067,8 +6067,8 @@ class DynamicalSystem_projective_field(DynamicalSystem_projective,
+@@ -6069,8 +6069,8 @@ class DynamicalSystem_projective_field(DynamicalSystem_projective,
sage: g = f.conjugate(m)
sage: f.conjugating_set(g) # long time
[
@@ -641,7 +641,7 @@ diff --git a/src/sage/geometry/polyhedron/library.py b/src/sage/geometry/polyhed
index d66997fc95..57a039d4d6 100644
--- a/src/sage/geometry/polyhedron/library.py
+++ b/src/sage/geometry/polyhedron/library.py
-@@ -2287,12 +2287,12 @@ class Polytopes():
+@@ -2286,12 +2286,12 @@ class Polytopes():
sage: perm_a2_reg = polytopes.generalized_permutahedron(['A',2],regular=True)
sage: perm_a2_reg.vertices()
@@ -658,7 +658,7 @@ index d66997fc95..57a039d4d6 100644
sage: perm_a2_reg.is_inscribed()
True
sage: perm_a3_reg = polytopes.generalized_permutahedron(['A',3],regular=True)
-@@ -2304,20 +2304,20 @@ class Polytopes():
+@@ -2303,20 +2303,20 @@ class Polytopes():
sage: perm_a2_inexact = polytopes.generalized_permutahedron(['A',2],exact=False)
sage: perm_a2_inexact.vertices()
(A vertex at (0.0, 1.0),
@@ -715,7 +715,7 @@ diff --git a/src/sage/graphs/generic_graph.py b/src/sage/graphs/generic_graph.py
index 9f7e1f418e..0ec459e7d3 100644
--- a/src/sage/graphs/generic_graph.py
+++ b/src/sage/graphs/generic_graph.py
-@@ -5212,7 +5212,7 @@ class GenericGraph(GenericGraph_pyx):
+@@ -5211,7 +5211,7 @@ class GenericGraph(GenericGraph_pyx):
This method is deprecated since Sage-4.4.1.alpha2. Please use instead:
sage: g.layout(layout = "planar", save_pos = True)
@@ -724,7 +724,7 @@ index 9f7e1f418e..0ec459e7d3 100644
"""
deprecation(24494, 'This method is replaced by the method layout. '
'Please use layout(layout="planar", save_pos=True) '
-@@ -5266,25 +5266,25 @@ class GenericGraph(GenericGraph_pyx):
+@@ -5265,25 +5265,25 @@ class GenericGraph(GenericGraph_pyx):
sage: g = graphs.PathGraph(10)
sage: g.layout(layout='planar', save_pos=True, test=True)
@@ -763,7 +763,7 @@ index 9f7e1f418e..0ec459e7d3 100644
sage: g = graphs.CompleteGraph(5)
sage: g.layout(layout='planar', save_pos=True, test=True, set_embedding=True)
Traceback (most recent call last):
-@@ -5810,17 +5810,17 @@ class GenericGraph(GenericGraph_pyx):
+@@ -5809,17 +5809,17 @@ class GenericGraph(GenericGraph_pyx):
sage: T = graphs.TetrahedralGraph()
sage: T.faces({0: [1, 3, 2], 1: [0, 2, 3], 2: [0, 3, 1], 3: [0, 1, 2]})
[[(0, 1), (1, 2), (2, 0)],
@@ -1238,7 +1238,7 @@ index 080509beb7..2385f1eae3 100644
::
-@@ -258,7 +258,7 @@ class SchemeMorphism_point_affine_field(SchemeMorphism_point_affine):
+@@ -259,7 +259,7 @@ class SchemeMorphism_point_affine_field(SchemeMorphism_point_affine):
sage: X = A.subscheme(x - y)
sage: hash(X([1, 1]))
1300952125 # 32-bit