summarylogtreecommitdiffstats
path: root/sdl2_bug.patch
diff options
context:
space:
mode:
authorAntoine Viallon2020-10-13 13:20:35 +0200
committerAntoine Viallon2020-10-13 13:20:35 +0200
commit4df24403b97d87b0f6da62072f40eff9275c17da (patch)
treec6bbbdd23e913b50c9655482118d99d20c6b9ef9 /sdl2_bug.patch
parent006196fd54c90883054218e2294c23de171a2d2b (diff)
downloadaur-4df24403b97d87b0f6da62072f40eff9275c17da.tar.gz
Fix sheepshaver build
Remove outdated configure flags Remove -j1, since building works without
Diffstat (limited to 'sdl2_bug.patch')
-rw-r--r--sdl2_bug.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/sdl2_bug.patch b/sdl2_bug.patch
new file mode 100644
index 000000000000..5506e913e339
--- /dev/null
+++ b/sdl2_bug.patch
@@ -0,0 +1,25 @@
+From b7bf5f6422f60e863051d1cfa3f067cd028a0bf8 Mon Sep 17 00:00:00 2001
+From: Darren Blaber <dmbtech@gmail.com>
+Date: Sat, 1 Aug 2020 17:54:23 -0400
+Subject: [PATCH] Fix configure.ac so sheepshaver builds with sdl2 changes
+
+ENABLE_SDL1 must be set after commit https://github.com/cebix/macemu/commit/a46759990d33d7d1e2c7bac01459747d6180eb76 or else
+symbols in video_sdl.cpp(VideoExit(), VideoInit() etc) will not be available, when building sheepshaver with
+--enable-sdl-video. Sheepshaver and BasiliskII share the same SDL code,
+so this must be changed as well.
+---
+ SheepShaver/src/Unix/configure.ac | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/SheepShaver/src/Unix/configure.ac b/SheepShaver/src/Unix/configure.ac
+index 006fe872..cb3baa0a 100644
+--- a/SheepShaver/src/Unix/configure.ac
++++ b/SheepShaver/src/Unix/configure.ac
+@@ -195,6 +195,7 @@ if [[ "x$WANT_SDL" = "xyes" ]]; then
+ fi
+ if [[ "x$ac_cv_framework_SDL" = "xno" ]]; then
+ AC_PATH_PROG(sdl_config, "sdl-config")
++ AC_DEFINE(ENABLE_SDL1, 1, [Define if using SDL1, sheepshaver only currenly supports 1.])
+ if [[ -n "$sdl_config" ]]; then
+ sdl_cflags=`$sdl_config --cflags`
+ if [[ "x$WANT_SDL_STATIC" = "xyes" ]]; then