aboutsummarylogtreecommitdiffstats
path: root/seawright.patch
diff options
context:
space:
mode:
authorseawright2021-02-07 00:30:43 +0000
committerseawright2021-02-07 00:30:43 +0000
commit585c1bccc7bfb83e750a833b46b20fd9e0f2c891 (patch)
treef1ee62e39807ba76184ea4a145414e82b6422009 /seawright.patch
parentc27ce6a75b9ba108b7c93bab4882c8b43ffdc32f (diff)
downloadaur-585c1bccc7bfb83e750a833b46b20fd9e0f2c891.tar.gz
Removed seawright.patch (no longer required).
Commented out galaxy.patch in PKGBUILD as necessary changes have been added upstream. Added extramodules.patch to ensure extramodules directory is created if it does not already exist.
Diffstat (limited to 'seawright.patch')
-rw-r--r--seawright.patch29
1 files changed, 0 insertions, 29 deletions
diff --git a/seawright.patch b/seawright.patch
deleted file mode 100644
index 28d34b0d1bc9..000000000000
--- a/seawright.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- a/setup/Linux/oss/build/osscore.c 2018-07-22 16:35:24.559690072 +0100
-+++ b/setup/Linux/oss/build/osscore.c 2018-07-22 16:39:42.948338371 +0100
-@@ -32,6 +32,7 @@
- #include <linux/sched.h>
- #include <linux/interrupt.h>
- #if LINUX_VERSION_CODE > KERNEL_VERSION(3,10,0)
-+#include <linux/cred.h>
- #include <linux/uidgid.h>
- #endif
- #undef strlen
-@@ -475,13 +476,17 @@
- unsigned int
- oss_get_uid (void)
- {
--#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,10,0)
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,13,0)
-+ return current->cred->uid.val;
-+#else
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,14,0)
- return __kuid_val(current->cred->uid);
- #elif LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,29)
- return current->cred->uid;
- #else
- return current->uid;
- #endif
-+#endif
- return 0;
- }
-