summarylogtreecommitdiffstats
path: root/servicewall.install
diff options
context:
space:
mode:
authorlafleurdeboum2019-04-07 22:16:50 +0200
committerlafleur2019-04-07 22:22:42 +0200
commite00440a3b90a04a66fd1101c0b3c9d9af53729a0 (patch)
tree81999c204d977cf2d246c735e4d1233a7507defb /servicewall.install
downloadaur-e00440a3b90a04a66fd1101c0b3c9d9af53729a0.tar.gz
initial PKGBUILD for servicewall firewall
Diffstat (limited to 'servicewall.install')
-rw-r--r--servicewall.install21
1 files changed, 21 insertions, 0 deletions
diff --git a/servicewall.install b/servicewall.install
new file mode 100644
index 000000000000..ae43ecf33206
--- /dev/null
+++ b/servicewall.install
@@ -0,0 +1,21 @@
+## arg 1: the new package version
+post_install() {
+ braise status | grep -q "enabled" || (
+ echo "To enable ServiceWall, issue a\n\t# braise enable"
+ )
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ braise status | grep -q "enabled" && (
+ echo "reloading ServiceWall";
+ braise reload
+ )
+}
+
+## arg 1: the old package version
+pre_remove() {
+ echo "disabling ServiceWall";
+ braise disable
+}