summarylogtreecommitdiffstats
path: root/setup.py-patch
diff options
context:
space:
mode:
authorRod Kay2018-09-07 13:41:28 +1000
committerRod Kay2018-09-07 13:41:28 +1000
commit907c4dee3e2a188bc6484547373b24b441ff852c (patch)
treef9597a16ff9cc2f414593f65d0b80cb5f783f1ee /setup.py-patch
downloadaur-907c4dee3e2a188bc6484547373b24b441ff852c.tar.gz
Initial commit
Diffstat (limited to 'setup.py-patch')
-rw-r--r--setup.py-patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/setup.py-patch b/setup.py-patch
new file mode 100644
index 000000000000..7e54684c0d59
--- /dev/null
+++ b/setup.py-patch
@@ -0,0 +1,11 @@
+--- setup.py 2018-08-29 01:02:26.566772927 +1000
++++ setup.py-new 2018-08-29 01:03:18.566772928 +1000
+@@ -82,7 +82,7 @@
+ # On Linux platform, even when linking with the static libpython,
+ # symbols not used by the application itself should be exported so
+ # that shared library present in Python can use the Python C API.
+- python_static_libs += ' -export-dynamic'
++ python_static_libs = ' -export-dynamic'
+ python_shared_libs += ' -export-dynamic'
+
+ logging.info(' %-24s %s', 'Shared linker flags', python_shared_libs)