summarylogtreecommitdiffstats
path: root/setup.py.patch
diff options
context:
space:
mode:
authorLuis Martinez2022-08-17 22:20:24 -0500
committerLuis Martinez2022-08-17 22:20:33 -0500
commit0eba1708a81fab48f84ab9383c8fd921d19ad046 (patch)
treeb06e95cca89cffe401c898b90efab5c6b6a38fd8 /setup.py.patch
parent762086f837f3df20c5b7dbd2e619680075082eb4 (diff)
downloadaur-0eba1708a81fab48f84ab9383c8fd921d19ad046.tar.gz
packaging cleanup
Diffstat (limited to 'setup.py.patch')
-rw-r--r--setup.py.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/setup.py.patch b/setup.py.patch
new file mode 100644
index 000000000000..2c4fa17c3922
--- /dev/null
+++ b/setup.py.patch
@@ -0,0 +1,26 @@
+diff --git a/setup.py b/setup.py
+index b46ee9c..0f044c9 100644
+--- a/setup.py
++++ b/setup.py
+@@ -1,19 +1,10 @@
+-import os
+ from setuptools import setup, find_packages
+
+-__version__ = None
+-pth = os.path.join(
+- os.path.dirname(os.path.realpath(__file__)),
+- "ngmix",
+- "_version.py")
+-with open(pth, 'r') as fp:
+- exec(fp.read())
+-
+ setup(
+ name="ngmix",
+ author="Erin Sheldon",
+ url="https://github.com/esheldon/ngmix",
+ description="fast 2-d gaussian mixtures for modeling astronomical images",
+- packages=find_packages(exclude=["mdet_tests"]),
+- version=__version__,
++ packages=find_packages(exclude=["mdet_tests", "ngmix.tests"]),
++ version='__version__',
+ )