summarylogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorLuke Arms2020-10-09 17:21:55 +1100
committerLuke Arms2020-10-09 17:21:55 +1100
commit3b3cc41c07d35f6b42c255e37709df666f068f3f (patch)
tree26b828ba8994fb71dfe8ed6c5b469f1b2bede56a /setup.py
downloadaur-3b3cc41c07d35f6b42c255e37709df666f068f3f.tar.gz
Initial commit
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py25
1 files changed, 25 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 000000000000..ca5177d7b558
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,25 @@
+import os
+from setuptools import setup
+
+
+setup(
+ name="Emote",
+ version=os.environ.get("EMOTE_VERSION"),
+ packages=["emote"],
+ setup_requires=["setuptools"],
+ entry_points={
+ "gui_scripts": [
+ "emote = emote.__init__:main",
+ ]
+ },
+ install_requires=[
+ "pygobject",
+ ],
+ package_data={
+ "emote": [
+ "static/*"
+ ]
+ },
+ data_files=[("share/applications", ["snap/gui/emote.desktop"]),
+ ("share/icons", ["snap/gui/emote.svg"])]
+)