summarylogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorLuke Arms2023-06-24 17:49:51 +1000
committerLuke Arms2023-06-24 17:49:51 +1000
commit61380fb06632979366ef340093e0ec3a39e1eea8 (patch)
treeccdec1fd0bbb3e030c5b938e0b5d5fa42167f314 /setup.py
parenta983f1b11d317320b2a192bea0193b208acea9fc (diff)
downloadaur-61380fb06632979366ef340093e0ec3a39e1eea8.tar.gz
Update to v4.0.1
- Remove patches after upstream changes - Update dependencies
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py21
1 files changed, 10 insertions, 11 deletions
diff --git a/setup.py b/setup.py
index b35a372c42a0..2431e8c1b037 100644
--- a/setup.py
+++ b/setup.py
@@ -1,10 +1,8 @@
-import os
from setuptools import setup
setup(
name="Emote",
- version=os.environ.get("EMOTE_VERSION"),
packages=["emote"],
setup_requires=["setuptools"],
entry_points={
@@ -13,14 +11,15 @@ setup(
]
},
install_requires=[
- "pygobject",
- "manimpango"
+ "manimpango",
+ "setproctitle",
+ "dbus-python",
+ ],
+ # This is relative to the emote package
+ package_data={"emote": ["static/*"]},
+ # Unlike these, which are relative to setup.py
+ data_files=[
+ ("share/applications", ["static/emote.desktop"]),
+ ("share/icons/hicolor/scalable/apps", ["static/emote.svg"]),
],
- package_data={
- "emote": [
- "static/*"
- ]
- },
- data_files=[("share/applications", ["snap/gui/emote.desktop"]),
- ("share/icons", ["snap/gui/emote.svg"])]
)