summarylogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorfabrixxm2016-11-27 08:55:37 +0100
committerDavid Vogt2016-11-29 11:05:22 +0100
commit25ac61f46cb706eed1a71dcdefdef340a6cdd008 (patch)
tree7e79781e25651b079396e30200e1cc7e6a7b0304 /setup.py
parent1845d00682bfbdff7101d44cda84522664916897 (diff)
downloadaur-25ac61f46cb706eed1a71dcdefdef340a6cdd008.tar.gz
Install without using virtualenv and pyinstaller
- install required python modules from repository - install pugdebug module in system python's 'site-packages' using provided setup.py and setuptools - install app.py script as /usr/bin/pugdebug - install .desktop file using icon from https://openclipart.org/detail/204954/dog
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 16 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 000000000000..ab7784519b20
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,16 @@
+import os
+from setuptools import setup, find_packages
+
+def read(fname):
+ return open(os.path.join(os.path.dirname(__file__), fname)).read()
+
+setup(
+ name = "pugdebug",
+ version = ":version:",
+ author = "robertbasic",
+ description = ("A standalone debugging client for PHP applications."),
+ license = "GPLv3+",
+ url = "https://github.com/robertbasic/pugdebug",
+ packages=find_packages(),
+ long_description=read('README.md'),
+)