summarylogtreecommitdiffstats
path: root/shadowgrounds-launcher.sh
diff options
context:
space:
mode:
authorEric Anderson2018-07-08 13:55:10 -0700
committerEric Anderson2018-07-08 13:55:10 -0700
commit5ce87ed99bbebc0fa24d23183657b2482ec165bb (patch)
tree698cdd48eaf6e6e4d1a17e46906e43f78a445e37 /shadowgrounds-launcher.sh
parentb581f65329452beb02eceb7649fbf002143b5f21 (diff)
downloadaur-5ce87ed99bbebc0fa24d23183657b2482ec165bb.tar.gz
Remove optdep for libtxc_dxtn; modernize PKGBUILD
libtxc_dxtn is no longer necessary, and is no longer available on the AUR, so remove the reference to reduce confusion. Remove the .install file because gtk2 now seems to use fallbacks if the engine is not available. Use bsdtar instead of unzip to avoid the makedep. Use exec in .sh since the bash process is useless while playing. The .SRCINFO shows more changes because it is showing the x86_64 deps now, which is apt since i686 is no longer supported by core Arch. I could remove support for i686, but leaving it since it may be useful to someone and isn't hurting anything.
Diffstat (limited to 'shadowgrounds-launcher.sh')
-rw-r--r--shadowgrounds-launcher.sh2
1 files changed, 1 insertions, 1 deletions
diff --git a/shadowgrounds-launcher.sh b/shadowgrounds-launcher.sh
index fa8c5661bf78..080290d90735 100644
--- a/shadowgrounds-launcher.sh
+++ b/shadowgrounds-launcher.sh
@@ -1,2 +1,2 @@
#!/bin/sh
-cd /opt/shadowgrounds && ./shadowgrounds-launcher $@
+cd /opt/shadowgrounds && exec ./shadowgrounds-launcher $@