summarylogtreecommitdiffstats
path: root/shared-mumps.patch
diff options
context:
space:
mode:
authorJoerg Behrmann2019-04-22 16:31:47 +0200
committerJoerg Behrmann2019-04-22 16:31:47 +0200
commitecf98224cbed68ab0c71833fdbc77c70a40826a5 (patch)
treed6ae918ebcf2826e543f9e9002b33b782b4649ae /shared-mumps.patch
parent0c11e5a860c564b01d73e58f65bbf8d425e1aabf (diff)
downloadaur-ecf98224cbed68ab0c71833fdbc77c70a40826a5.tar.gz
update to new upstream version 5.2.0
Diffstat (limited to 'shared-mumps.patch')
-rw-r--r--shared-mumps.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/shared-mumps.patch b/shared-mumps.patch
index 1cba747cac65..35432e7f9acf 100644
--- a/shared-mumps.patch
+++ b/shared-mumps.patch
@@ -30,16 +30,16 @@ Index: mumps/src/Makefile
-$(libdir)/lib$(ARITH)mumps$(PLAT)$(LIBEXT): $(OBJS_MOD) $(OBJS_OTHER)
- $(AR)$@ $?
+$(libdir)/libmumps_common$(PLAT).so: $(OBJS_COMMON_MOD) $(OBJS_COMMON_OTHER)
-+ $(FC) -shared $^ -Wl,-soname,libmumps_common$(PLAT)-5.1.2.so -L$(libdir) $(LORDERINGS) -lpthread $(MPIFLIB) $(MPICLIB) -o $(libdir)/libmumps_common$(PLAT)-5.1.2.so -Wl,-z,defs
-+ ln -s libmumps_common$(PLAT)-5.1.2.so $@
++ $(FC) -shared $^ -Wl,-soname,libmumps_common$(PLAT)-5.2.0.so -L$(libdir) $(LORDERINGS) -lpthread $(MPIFLIB) $(MPICLIB) -o $(libdir)/libmumps_common$(PLAT)-5.2.0.so -Wl,-z,defs
++ ln -s libmumps_common$(PLAT)-5.2.0.so $@
+
+$(libdir)/lib$(ARITH)mumps$(PLAT).a: $(OBJS_MOD) $(OBJS_OTHER)
+ $(AR) $@ $?
$(RANLIB) $@
+$(libdir)/lib$(ARITH)mumps$(PLAT).so: $(OBJS_MOD) $(OBJS_OTHER)
-+ $(FC) -shared $^ -Wl,-soname,lib$(ARITH)mumps$(PLAT)-5.1.2.so -L$(libdir) -lmumps_common$(PLAT) $(LORDERINGS) $(MPIFLIB) -lblas $(SCALAP) $(LAPACK) -o $(libdir)/lib$(ARITH)mumps$(PLAT)-5.1.2.so -Wl,-z,defs
-+ ln -s lib$(ARITH)mumps$(PLAT)-5.1.2.so $@
++ $(FC) -shared $^ -Wl,-soname,lib$(ARITH)mumps$(PLAT)-5.2.0.so -L$(libdir) -lmumps_common$(PLAT) $(LORDERINGS) $(MPIFLIB) -lblas $(SCALAP) $(LAPACK) -o $(libdir)/lib$(ARITH)mumps$(PLAT)-5.2.0.so -Wl,-z,defs
++ ln -s lib$(ARITH)mumps$(PLAT)-5.2.0.so $@
+
# Dependencies between modules:
$(ARITH)mumps_load.o: $(ARITH)mumps_comm_buffer.o \