summarylogtreecommitdiffstats
path: root/size-optimisations.patch
diff options
context:
space:
mode:
authorMikołaj "D1SoveR" Banasik2022-11-19 14:04:24 +0000
committerMikołaj "D1SoveR" Banasik2022-11-19 14:05:21 +0000
commit2e69df7183c1cfbe6ce341b299c6bea181fae10a (patch)
treee0b8df389ac6e5f02dcb851b35f489d58025031b /size-optimisations.patch
parentba24e0a45bc5061a770bd56db4390699181ab2c0 (diff)
downloadaur-2e69df7183c1cfbe6ce341b299c6bea181fae10a.tar.gz
Updated patches to account for changes to Cargo.toml and the Makefile.
Diffstat (limited to 'size-optimisations.patch')
-rw-r--r--size-optimisations.patch12
1 files changed, 6 insertions, 6 deletions
diff --git a/size-optimisations.patch b/size-optimisations.patch
index e60f9e6d960f..7c7c1902011f 100644
--- a/size-optimisations.patch
+++ b/size-optimisations.patch
@@ -1,10 +1,10 @@
diff --git a/Cargo.toml b/Cargo.toml
-index 558ceb5..913630d 100644
+index 5541e99..cda7add 100644
--- a/Cargo.toml
+++ b/Cargo.toml
-@@ -6,6 +6,11 @@ edition = "2018"
-
- # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+@@ -9,6 +9,11 @@ edition = "2021"
+ [lib]
+ crate-type = ["cdylib"]
+[profile.release]
+panic = 'abort'
@@ -12,5 +12,5 @@ index 558ceb5..913630d 100644
+lto = true
+
[dependencies]
- serde = { version = "1.0", features = ["derive"] }
- serde_json = "1.0"
+ serde = { version = "1.0.137", features = ["derive"] }
+ serde_json = "1.0.81"