summarylogtreecommitdiffstats
path: root/slim-1.3.6-fix-libslim-libraries.patch
diff options
context:
space:
mode:
authorBrian Bidulock2014-05-08 17:27:51 -0600
committerBrian Bidulock2015-07-16 01:03:41 -0600
commit2a803b935cbf50fe53cf3bd394bbadcd85adc598 (patch)
treeef1ec1ffd9d56b33e1c1c05d817aed09f7ec578c /slim-1.3.6-fix-libslim-libraries.patch
parent4b1c60b926fbdc36b54bc82916d4e722890b3e33 (diff)
downloadaur-2a803b935cbf50fe53cf3bd394bbadcd85adc598.tar.gz
version v1.3.6.3.g741e439.2013.10.03-1
Diffstat (limited to 'slim-1.3.6-fix-libslim-libraries.patch')
-rw-r--r--slim-1.3.6-fix-libslim-libraries.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/slim-1.3.6-fix-libslim-libraries.patch b/slim-1.3.6-fix-libslim-libraries.patch
new file mode 100644
index 000000000000..b6c90f9f46e3
--- /dev/null
+++ b/slim-1.3.6-fix-libslim-libraries.patch
@@ -0,0 +1,20 @@
+diff -upr slim-1.3.6.orig/CMakeLists.txt slim-1.3.6/CMakeLists.txt
+--- slim-1.3.6.orig/CMakeLists.txt 2013-10-02 16:16:22.000000000 +0300
++++ slim-1.3.6/CMakeLists.txt 2013-10-02 16:19:57.000000000 +0300
+@@ -119,6 +119,7 @@ if(USE_PAM)
+ if(PAM_FOUND)
+ message("\tPAM Found")
+ set(SLIM_DEFINITIONS ${SLIM_DEFINITIONS} "-DUSE_PAM")
++ target_link_libraries(libslim ${PAM_LIBRARY})
+ target_link_libraries(${PROJECT_NAME} ${PAM_LIBRARY})
+ target_link_libraries(slimlock ${PAM_LIBRARY})
+ include_directories(${PAM_INCLUDE_DIR})
+@@ -178,6 +179,8 @@ include_directories(
+ )
+
+ target_link_libraries(libslim
++ ${X11_Xft_LIB}
++ ${X11_Xrandr_LIB}
+ ${JPEG_LIBRARIES}
+ ${PNG_LIBRARIES}
+ )