summarylogtreecommitdiffstats
path: root/smoffice2012.install
diff options
context:
space:
mode:
authorjdarch2015-11-30 12:38:46 +0100
committerjdarch2015-11-30 12:38:46 +0100
commit9fed49fb2b9587c827fb730f4b854f5995fee1c8 (patch)
treed31b6e1210cf660d56b82e165a0f9eb90bfb9cb3 /smoffice2012.install
parente3e266d2cac640807c75d0e1984ddf24bbf922b6 (diff)
downloadaur-9fed49fb2b9587c827fb730f4b854f5995fee1c8.tar.gz
Update to simplify the PKGBUILD
Diffstat (limited to 'smoffice2012.install')
-rw-r--r--smoffice2012.install14
1 files changed, 9 insertions, 5 deletions
diff --git a/smoffice2012.install b/smoffice2012.install
index 5a3a5463215c..9f9a52e6de96 100644
--- a/smoffice2012.install
+++ b/smoffice2012.install
@@ -1,13 +1,17 @@
-post_install() {
- update-desktop-database -q
- update-mime-database usr/share/mime
+do_update() {
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-mime-database usr/share/mime &> /dev/null
+ update-desktop-database -q
+}
+
+post_install() {
+ do_update
}
post_upgrade() {
- post_install
+ do_update
}
post_remove () {
- post_install
+ do_update
}