aboutsummarylogtreecommitdiffstats
path: root/st.c
diff options
context:
space:
mode:
authorAurélien Aptel2010-08-27 13:53:27 +0200
committerAurélien Aptel2010-08-27 13:53:27 +0200
commit0fd136dd879a788d42eb87ec3d46342b7fe889e9 (patch)
tree53e20385e78361a2376b913783033f03f7c4fcf9 /st.c
parent7687ef28817a28b21d45af292dba7efd05417456 (diff)
downloadaur-0fd136dd879a788d42eb87ec3d46342b7fe889e9.tar.gz
removed XINERAMA from config.mk and fixed a segfault when st is
started without a display. (thx Hiltjo Posthuma)
Diffstat (limited to 'st.c')
-rw-r--r--st.c5
1 files changed, 2 insertions, 3 deletions
diff --git a/st.c b/st.c
index 8dfd4a75a197..623ca29cd71e 100644
--- a/st.c
+++ b/st.c
@@ -1078,10 +1078,9 @@ xhints(void)
void
xinit(void) {
- xw.dis = XOpenDisplay(NULL);
- xw.scr = XDefaultScreen(xw.dis);
- if(!xw.dis)
+ if(!(xw.dis = XOpenDisplay(NULL)))
die("Can't open display\n");
+ xw.scr = XDefaultScreen(xw.dis);
/* font */
if(!(dc.font = XLoadQueryFont(xw.dis, FONT)) || !(dc.bfont = XLoadQueryFont(xw.dis, BOLDFONT)))