summarylogtreecommitdiffstats
path: root/stp_remove_install_hooks.patch
diff options
context:
space:
mode:
authorChristian Rebischke2018-02-24 20:28:27 +0100
committerChristian Rebischke2018-02-24 20:28:27 +0100
commitc012fdf64ef3a3a105a239574e241e8cbefb29ea (patch)
tree7f1b5304167d90846219fc4338b397526797e468 /stp_remove_install_hooks.patch
parent68ebb460827c10678fcf49dbddaf03c101dc4fb9 (diff)
downloadaur-c012fdf64ef3a3a105a239574e241e8cbefb29ea.tar.gz
removed the install hooks
See also: https://bugs.archlinux.org/task/56853
Diffstat (limited to 'stp_remove_install_hooks.patch')
-rw-r--r--stp_remove_install_hooks.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/stp_remove_install_hooks.patch b/stp_remove_install_hooks.patch
new file mode 100644
index 000000000000..244ac833c5f3
--- /dev/null
+++ b/stp_remove_install_hooks.patch
@@ -0,0 +1,37 @@
+diff --git a/stapbpf/Makefile.am b/stapbpf/Makefile.am
+index a303d25f6..703668362 100644
+--- a/stapbpf/Makefile.am
++++ b/stapbpf/Makefile.am
+@@ -38,14 +38,4 @@ CLEANFILES =
+ BUILT_SOURCES += git_version.stamp
+ git_version.stamp ../git_version.h:
+ $(MAKE) -C .. $(notdir $@)
+-
+-# Why the "id -u" condition? This way, an unprivileged user can run
+-# make install, and have "sudo stap ...." or "sudo stapbpf ...." work later.
+-install-exec-hook:
+- if [ `id -u` -eq 0 ]; then \
+- getent group stapusr >/dev/null || groupadd -g 156 -r stapusr 2>/dev/null || groupadd -r stapusr; \
+- getent group stapusr >/dev/null \
+- && chgrp stapusr "$(DESTDIR)$(bindir)/stapbpf" \
+- && chmod 04110 "$(DESTDIR)$(bindir)/stapbpf"; \
+- fi
+ endif
+diff --git a/staprun/Makefile.am b/staprun/Makefile.am
+index 4073aa01c..978d115f9 100644
+--- a/staprun/Makefile.am
++++ b/staprun/Makefile.am
+@@ -68,13 +68,3 @@ CLEANFILES =
+ BUILT_SOURCES += git_version.stamp
+ git_version.stamp ../git_version.h:
+ $(MAKE) -C .. $(notdir $@)
+-
+-
+-# Why the "id -u" condition? This way, an unprivileged user can run
+-# make install, and have "sudo stap ...." or "sudo staprun ...." work later.
+-install-exec-hook:
+- if [ `id -u` -eq 0 ]; then \
+- getent group stapusr >/dev/null || groupadd -g 156 -r stapusr 2>/dev/null || groupadd -r stapusr; \
+- getent group stapusr >/dev/null && chgrp stapusr "$(DESTDIR)$(bindir)/staprun"; \
+- chmod 04110 "$(DESTDIR)$(bindir)/staprun"; \
+- fi