summarylogtreecommitdiffstats
path: root/strip-type-checking-deps.patch
diff options
context:
space:
mode:
authorAlexBocken2023-05-24 12:05:30 +0200
committerAlexBocken2023-05-24 12:05:30 +0200
commitb3da88a0fbd96864d7fec1671187680653d1286d (patch)
treeb3ded76151177cc0d9927033d589492d6c82e39c /strip-type-checking-deps.patch
parent7ab84c7359f9a757b09423e56137a994460815e1 (diff)
downloadaur-b3da88a0fbd96864d7fec1671187680653d1286d.tar.gz
bump to 2.1.64, major PKGBUILD overhaul
Diffstat (limited to 'strip-type-checking-deps.patch')
-rw-r--r--strip-type-checking-deps.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/strip-type-checking-deps.patch b/strip-type-checking-deps.patch
new file mode 100644
index 000000000000..36b08b2931d6
--- /dev/null
+++ b/strip-type-checking-deps.patch
@@ -0,0 +1,23 @@
+We don't do type checking (via mypy and related) downstream.
+Mypy-protobuf generates mypy stub files from protobuf specs and should
+therefore be stripped.
+--- a/build/configure/src/python.rs
++++ b/build/configure/src/python.rs
+@@ -86,9 +86,7 @@ pub struct GenPythonProto {
+ impl BuildAction for GenPythonProto {
+ fn command(&self) -> &str {
+ "$protoc $
+- --plugin=protoc-gen-mypy=$protoc-gen-mypy $
+ --python_out=$builddir/pylib $
+- --mypy_out=$builddir/pylib $
+ -Iproto $in"
+ }
+
+@@ -106,7 +104,6 @@ impl BuildAction for GenPythonProto {
+ .collect();
+ build.add_inputs("in", &self.proto_files);
+ build.add_inputs("protoc", inputs!["$protoc_binary"]);
+- build.add_inputs("protoc-gen-mypy", inputs![":pyenv:protoc-gen-mypy"]);
+ build.add_outputs("", python_outputs);
+ }
+ }