summarylogtreecommitdiffstats
path: root/subprocess-check_output.patch
diff options
context:
space:
mode:
authorPedro A. López-Valencia2023-02-10 10:50:44 -0500
committerPedro A. López-Valencia2023-02-10 10:50:44 -0500
commitc11daf57858b2704079f974bf5c573c5a8d3c490 (patch)
tree16e4b5a09c224ccd1000e80731f99a6f5fab95ff /subprocess-check_output.patch
parent635670d3f18bca8be53aef4a5a29d5c883dbfb60 (diff)
downloadaur-c11daf57858b2704079f974bf5c573c5a8d3c490.tar.gz
* Give a lot of TLC to the PKGBUILD. Move to use the upstream release
package. * See kids? The above is what the EPOCH field is there for. * Add patch to fix wrong text string is pressumed while path indexing is retreived as a binary string. Reported by bartus in 2020-01-26 but I did not see it until today, 2023-02-07. My apologies, personal issues have kept me out-of-touch with many activities including the AUR in last 4 years. Besides, I replaced BTRFS with F2FS like 6 years ago. ::smile::
Diffstat (limited to 'subprocess-check_output.patch')
-rw-r--r--subprocess-check_output.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/subprocess-check_output.patch b/subprocess-check_output.patch
new file mode 100644
index 000000000000..11f04ab93f06
--- /dev/null
+++ b/subprocess-check_output.patch
@@ -0,0 +1,12 @@
+diff -urN a/src/compress b/src/compress
+--- a/src/compress 2019-02-21 06:44:17.000000000 -0500
++++ b/src/compress 2023-02-10 10:38:24.963134333 -0500
+@@ -52,7 +52,7 @@
+ result = subprocess.check_output(["lsattr", path]).strip()
+ if (result == ''):
+ raise Exception('lsattr returned nothing')
+- result = result[:result.index(" ")]
++ result = result[:result.index(b' ')]
+ for f in result:
+ if (f == 'c'):
+ return True