summarylogtreecommitdiffstats
path: root/swap_pugixml.patch
diff options
context:
space:
mode:
authorAlex Hirzel2020-11-25 19:29:34 -0500
committerAlex Hirzel2020-11-26 08:29:36 -0500
commit2a622f6486430cfa6286822b44b4e112415ed1bb (patch)
treef73898fd9c20725c44abf3c2aa4db2ae8e9ae634 /swap_pugixml.patch
downloadaur-2a622f6486430cfa6286822b44b4e112415ed1bb.tar.gz
initial version
Diffstat (limited to 'swap_pugixml.patch')
-rw-r--r--swap_pugixml.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/swap_pugixml.patch b/swap_pugixml.patch
new file mode 100644
index 000000000000..19e16e0e9cb1
--- /dev/null
+++ b/swap_pugixml.patch
@@ -0,0 +1,42 @@
+diff --git a/ext/CMakeLists.txt b/ext/CMakeLists.txt
+index 337813dc..a353ee20 100644
+--- a/ext/CMakeLists.txt
++++ b/ext/CMakeLists.txt
+@@ -200,13 +200,7 @@ if (MTS_ENABLE_GUI)
+ endif()
+
+ # Build the pugixml parser
+-add_library(pugixml SHARED pugixml/src/pugixml.cpp)
+-set_property(TARGET pugixml PROPERTY
+- LIBRARY_OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/pugixml")
+-set_property(TARGET pugixml PROPERTY FOLDER "dependencies")
+-set(PUGIXML_INCLUDE_DIRS ${CMAKE_CURRENT_SOURCE_DIR}/pugixml/src PARENT_SCOPE)
+-set_property(SOURCE pugixml/src/pugixml.cpp
+- APPEND PROPERTY COMPILE_DEFINITIONS PUGIXML_BUILD_DLL)
++find_package(pugixml CONFIG)
+
+ # Build ZeroMQ
+ # set(WITH_SODIUM OFF CACHE BOOL " " FORCE)
+diff --git a/src/libcore/CMakeLists.txt b/src/libcore/CMakeLists.txt
+index b8b2d88c..d04a4e04 100644
+--- a/src/libcore/CMakeLists.txt
++++ b/src/libcore/CMakeLists.txt
+@@ -89,8 +89,7 @@ target_link_libraries(mitsuba-core PRIVATE
+ #
+ if (UNIX AND NOT APPLE)
+ target_link_libraries(mitsuba-core PUBLIC
+- -Wl,-rpath-link=$<TARGET_FILE_DIR:tbb>
+- -Wl,-rpath-link=$<TARGET_FILE_DIR:pugixml>)
++ -Wl,-rpath-link=$<TARGET_FILE_DIR:tbb>)
+ endif()
+
+ if (${CMAKE_SYSTEM_PROCESSOR} MATCHES "x86_64|AMD64")
+@@ -103,7 +102,7 @@ if (${CMAKE_SYSTEM_PROCESSOR} MATCHES "x86_64|AMD64")
+ endif()
+
+ # Copy to 'dist' directory
+-add_dist(mitsuba-core pugixml IlmThread Half Half Imath IlmImf Iex tbb)
++add_dist(mitsuba-core IlmThread Half Half Imath IlmImf Iex tbb)
+
+ if (CMAKE_CXX_COMPILER_ID MATCHES "^(GNU)$")
+ target_link_libraries(mitsuba-core PRIVATE -Wl,--no-undefined)