summarylogtreecommitdiffstats
path: root/swap_pybind_enoki.patch
diff options
context:
space:
mode:
authorAlex Hirzel2020-11-25 19:29:34 -0500
committerAlex Hirzel2020-11-26 08:29:36 -0500
commit2a622f6486430cfa6286822b44b4e112415ed1bb (patch)
treef73898fd9c20725c44abf3c2aa4db2ae8e9ae634 /swap_pybind_enoki.patch
downloadaur-2a622f6486430cfa6286822b44b4e112415ed1bb.tar.gz
initial version
Diffstat (limited to 'swap_pybind_enoki.patch')
-rw-r--r--swap_pybind_enoki.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/swap_pybind_enoki.patch b/swap_pybind_enoki.patch
new file mode 100644
index 000000000000..8e2a26fff778
--- /dev/null
+++ b/swap_pybind_enoki.patch
@@ -0,0 +1,18 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index c886fa5..91213f0 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -337,12 +337,10 @@ if (ENOKI_AUTODIFF)
+ endif()
+
+ if (ENOKI_PYTHON)
+- set(ENOKI_PYBIND11_DIR "${CMAKE_CURRENT_SOURCE_DIR}/ext/pybind11"
+- CACHE STRING "Path containing the 'pybind11' library used to compile Enoki.")
+ message(STATUS "Enoki: building the Python plugin.")
+
+ set(CMAKE_CXX_STANDARD 17)
+- add_subdirectory(${ENOKI_PYBIND11_DIR} pybind11)
++ find_package(pybind11 CONFIG)
+
+ pybind11_add_module(
+ enoki-python-core