summarylogtreecommitdiffstats
path: root/swig4.patch
diff options
context:
space:
mode:
authorChris Oelmueller2020-01-03 21:13:24 +0100
committerChris Oelmueller2020-01-03 21:48:35 +0100
commit0d13ad4dbacb0f555961e2fd5f24688deca18043 (patch)
tree947f213becb34671c6365c6294c10bdd58a24801 /swig4.patch
parent94ae5cb2688db914be8a718ffc38dc106be8ca89 (diff)
downloadaur-0d13ad4dbacb0f555961e2fd5f24688deca18043.tar.gz
fife-git: Update PKGBUILD for swig4
People still updating or building this are likely to have updated their SWIG by now. If you're reading this from the future: Yeah, me lazy again! Via https://github.com/fifengine/fifengine/commit/d14f232f4cd9a00b05
Diffstat (limited to 'swig4.patch')
-rw-r--r--swig4.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/swig4.patch b/swig4.patch
new file mode 100644
index 000000000000..d2318e71aa80
--- /dev/null
+++ b/swig4.patch
@@ -0,0 +1,22 @@
+From d14f232f4cd9a00b05d6872957070e8c020f515d Mon Sep 17 00:00:00 2001
+From: Thomas Kowaliczek-Schmer <linuxdonald@posteo.de>
+Date: Wed, 22 May 2019 16:04:43 +0200
+Subject: [PATCH] removed flags that are not supported with swig 4.0
+
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 126322ce0..25c695630 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -893,7 +893,7 @@ if(build-python)
+ find_package(PythonLibs ${PYTHON_VERSION_STRING} EXACT)
+ include_directories(${PYTHON_INCLUDE_PATH})
+
+- set(CMAKE_SWIG_FLAGS -modern -fastdispatch -dirvtable -nosafecstrings -noproxydel -fastproxy -fastinit -fastunpack -fastquery -modernargs -nobuildnone -keyword -w511 -w473 -w404 -w314)
++ set(CMAKE_SWIG_FLAGS -fastdispatch -dirvtable -fastproxy -keyword -w511 -w473 -w404 -w314)
+
+ set_source_files_properties("${PROJECT_BINARY_DIR}/fife.i" PROPERTIES CPLUSPLUS ON)
+ set(FIFE_SOURCES ${FIFE_CORE_SRC})