summarylogtreecommitdiffstats
path: root/system-xxhash.patch
diff options
context:
space:
mode:
authorMagnus Boman2023-05-12 20:19:05 +0200
committerMagnus Boman2023-05-12 20:19:05 +0200
commitc7b32aa7ce2743a3572843a416e0be880a7feebf (patch)
tree61eef74079f6168df94762e408eed5b47e7fb4e6 /system-xxhash.patch
parent8e0e4f28f646c7f7bbe5ac2871fe9e4e6c54e239 (diff)
downloadaur-c7b32aa7ce2743a3572843a416e0be880a7feebf.tar.gz
upgpkg: jdupes-git 1.23.0.r0.gae3cce7-1
build with system libxxhash
Diffstat (limited to 'system-xxhash.patch')
-rw-r--r--system-xxhash.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/system-xxhash.patch b/system-xxhash.patch
new file mode 100644
index 000000000000..f1742ccc7ada
--- /dev/null
+++ b/system-xxhash.patch
@@ -0,0 +1,40 @@
+diff --git a/Makefile b/Makefile
+index efbd1ce..285e373 100644
+--- a/Makefile
++++ b/Makefile
+@@ -139,7 +139,8 @@ COMPILER_OPTIONS += -DUSE_JODY_HASH
+ OBJS_CLEAN += xxhash.o
+ else
+ ifndef EXTERNAL_HASH_LIB
+-OBJS += xxhash.o
++CFLAGS += `pkg-config --cflags libxxhash`
++LDFLAGS += `pkg-config --libs libxxhash`
+ endif
+ endif # USE_JODY_HASH
+
+diff --git a/jdupes.c b/jdupes.c
+index f47dfed..27bd3c5 100644
+--- a/jdupes.c
++++ b/jdupes.c
+@@ -42,7 +42,7 @@
+ #include <sys/time.h>
+ #include "jdupes.h"
+ #ifndef USE_JODY_HASH
+- #include "xxhash.h"
++ #include <xxhash.h>
+ #endif
+ #ifdef ENABLE_DEDUPE
+ #include <sys/utsname.h>
+diff --git a/jdupes.h b/jdupes.h
+index 185e630..e375bb0 100644
+--- a/jdupes.h
++++ b/jdupes.h
+@@ -30,7 +30,7 @@ extern "C" {
+ #include <libjodycode.h>
+
+ #ifndef USE_JODY_HASH
+-#include "xxhash.h"
++#include <xxhash.h>
+ #endif /* USE_JODY_HASH */
+
+ /* Set hash type (change this if swapping in a different hash function) */