summarylogtreecommitdiffstats
path: root/taskd.notes
diff options
context:
space:
mode:
authorPablo Couto2015-04-26 18:01:35 +0200
committerPablo Couto2015-07-05 01:34:58 +0200
commit4cd8c31cbd110216d53ea10ce6d7f5468a1c5f42 (patch)
treeb9303afadffca31834427e0a1079a1ba41e8bbe3 /taskd.notes
parent4c8f6a003c40cd67c6370ef6d5d0144e80682e1d (diff)
downloadaur-4cd8c31cbd110216d53ea10ce6d7f5468a1c5f42.tar.gz
functional PKGBUILD
Diffstat (limited to 'taskd.notes')
-rw-r--r--taskd.notes28
1 files changed, 17 insertions, 11 deletions
diff --git a/taskd.notes b/taskd.notes
index 02dbf40e8556..05fc5a4ed353 100644
--- a/taskd.notes
+++ b/taskd.notes
@@ -1,7 +1,14 @@
-# Reference http://taskwarrior.org/docs/server_setup.html
+# Taskserver configuration reference can be found at
+# http://taskwarrior.org/docs/server_setup.html
-# Add the taskd group to your user and logout and back in.
-# sudo usermod -a -G taskd $USER
+# In order to control the server as a user, add the taskd group to your user.
+#
+# $ sudo usermod -a -G taskd $USER
+# $ exec newgrp taskd
+
+# Before anything else, set the configuration variables in /etc/conf.d/taskd
+# (server storage and other conf) and /usr/lib/taskd/pki/var (certificates
+# generation).
# Source the environment variable(s).
export $(cat /etc/conf.d/taskd)
@@ -9,12 +16,6 @@ export $(cat /etc/conf.d/taskd)
# Initialize the database
taskd init
-# Add the organization
-taskd add org Public
-
-# Add your user
-task add user 'Public' 'Your Name' > ~/taskd.key
-
# Generate and install your self-signed cert
cd /usr/lib/taskd/pki
sudo ./generate
@@ -31,5 +32,10 @@ taskd config --force ca.cert $TASKDDATA/ca.cert.pem
# Various settings
taskd config --force log $TASKDDATA/taskd.log
taskd config --force pid.file $TASKDDATA/taskd.pid
-taskd config --force server localhost:53859
-taskd config --force client.allow '^task [2-9]'
+taskd config --force server $TASKDSERVER:$TASKDPORT
+
+# Add the organization
+# $ taskd add org Public
+
+# Add your user
+# $ task add user 'Public' 'Your Name' > ~/taskd.key