summarylogtreecommitdiffstats
path: root/tor-browser.sh
diff options
context:
space:
mode:
authorgrufo2019-10-25 22:30:32 +0100
committergrufo2019-10-25 22:30:32 +0100
commit57b148bccd632b090655158d333318be8488fffc (patch)
tree70c2a6eb9ffc75fac6d7d3121e106fcd726eac2e /tor-browser.sh
parent9b97d1f12ee08516e8f887b8f870ab40f2819970 (diff)
downloadaur-57b148bccd632b090655158d333318be8488fffc.tar.gz
PKGBUILD: only
Diffstat (limited to 'tor-browser.sh')
-rwxr-xr-xtor-browser.sh13
1 files changed, 10 insertions, 3 deletions
diff --git a/tor-browser.sh b/tor-browser.sh
index 6e14ef0a6794..2ca37f23c427 100755
--- a/tor-browser.sh
+++ b/tor-browser.sh
@@ -22,6 +22,8 @@
set -e
+# CONSTANTS AND VARIABLES
+
# filled by PKGBUILD
_TB_PKGNAME_='__REPL_NAME__'
_TB_VERSION_='__REPL_VERSION__'
@@ -31,12 +33,11 @@ _TB_ARCH_='__REPL_ARCH__'
# other constants and variables
_TB_HOME_DIR_=~/".${_TB_PKGNAME_}"
-_TB_VER_FILE_="${_TB_HOME_DIR_}/VERSION"
-_TB_LOG_FILE_="${_TB_HOME_DIR_}/LOG"
-_TB_APP_DIR_="${_TB_HOME_DIR_}/app"
_TB_REFRESH_=0
+# FUNCTIONS
+
# syntax: _notify_ "${TITLE}" "${MESSAGE}"
_notify_() {
@@ -150,6 +151,8 @@ EOF
}
+# SCRIPT BODY
+
args=()
for arg; do
case "${arg}" in
@@ -162,6 +165,10 @@ for arg; do
esac
done
+_TB_VER_FILE_="${_TB_HOME_DIR_}/VERSION"
+_TB_LOG_FILE_="${_TB_HOME_DIR_}/LOG"
+_TB_APP_DIR_="${_TB_HOME_DIR_}/app"
+
# create directory, if it is missing (e.g. first run)
[[ ! -d "${_TB_APP_DIR_}" ]] && mkdir -p "${_TB_APP_DIR_}"
cd "${_TB_HOME_DIR_}"