summarylogtreecommitdiffstats
path: root/trim-executables.diff
diff options
context:
space:
mode:
authorGiovanni Santini2021-09-09 23:51:14 +0200
committerGiovanni Santini2021-09-10 00:13:13 +0200
commit2b6b822823efc91579b370c730decf5a5b8fede9 (patch)
tree4882f08725d0e27866a9633f81b7a39f79bdc81e /trim-executables.diff
downloadaur-2b6b822823efc91579b370c730decf5a5b8fede9.tar.gz
newpkg: git-credential-manager-core 2.0.498
- Initial release. Package written from scratch using the PKGBUILD template within `pacman`. - Validated agains `namcap` as much as possible.
Diffstat (limited to 'trim-executables.diff')
-rw-r--r--trim-executables.diff28
1 files changed, 28 insertions, 0 deletions
diff --git a/trim-executables.diff b/trim-executables.diff
new file mode 100644
index 000000000000..b1b9ce81ec8a
--- /dev/null
+++ b/trim-executables.diff
@@ -0,0 +1,28 @@
+diff --git a/src/linux/Packaging.Linux/build.sh b/src/linux/Packaging.Linux/build.sh
+index f1c7473..7904b91 100755
+--- a/src/linux/Packaging.Linux/build.sh
++++ b/src/linux/Packaging.Linux/build.sh
+@@ -98,6 +98,7 @@ dotnet publish "$GCM_SRC" \
+ --runtime="$RUNTIME" \
+ --self-contained=true \
+ -p:PublishSingleFile=true \
++ -p:PublishTrimmed=true \
+ --output="$(make_absolute "$PAYLOAD")" || exit 1
+
+ echo "Publishing Bitbucket UI helper..."
+@@ -107,6 +108,7 @@ dotnet publish "$BITBUCKET_UI_SRC" \
+ --runtime="$RUNTIME" \
+ --self-contained=true \
+ -p:PublishSingleFile=true \
++ -p:PublishTrimmed=true \
+ --output="$(make_absolute "$PAYLOAD")" || exit 1
+
+ echo "Publishing GitHub UI helper..."
+@@ -116,6 +118,7 @@ dotnet publish "$GITHUB_UI_SRC" \
+ --runtime="$RUNTIME" \
+ --self-contained=true \
+ -p:PublishSingleFile=true \
++ -p:PublishTrimmed=true \
+ --output="$(make_absolute "$PAYLOAD")" || exit 1
+
+ # Collect symbols