summarylogtreecommitdiffstats
path: root/uefipatch.cpp.patch
diff options
context:
space:
mode:
authorAlexander Rubinov2016-10-08 00:11:59 +0200
committerAlexander Rubinov2016-10-08 00:11:59 +0200
commit9f16287f9663fef5b8db75ed82511e6d0eb59cfd (patch)
treed51261a6addd7d47d5ed7f1710a885939ad6ab1d /uefipatch.cpp.patch
parentb9ed282d08ac0d2558829f0635f869e472a282d3 (diff)
downloadaur-9f16287f9663fef5b8db75ed82511e6d0eb59cfd.tar.gz
default path for patches.txt, reworked PKGBUILD
Diffstat (limited to 'uefipatch.cpp.patch')
-rw-r--r--uefipatch.cpp.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/uefipatch.cpp.patch b/uefipatch.cpp.patch
new file mode 100644
index 000000000000..7bd86073ea84
--- /dev/null
+++ b/uefipatch.cpp.patch
@@ -0,0 +1,18 @@
+--- a/uefitool/UEFIPatch/uefipatch.cpp 2016-10-07 23:39:16.579188249 +0200
++++ b/uefitool/UEFIPatch/uefipatch.cpp 2016-10-07 23:40:00.707034736 +0200
+@@ -27,13 +27,13 @@
+
+ UINT8 UEFIPatch::patchFromFile(QString path)
+ {
+- QFileInfo patchInfo = QFileInfo("patches.txt");
++ QFileInfo patchInfo = QFileInfo("/usr/share/uefitool/patches.txt");
+
+ if (!patchInfo.exists())
+ return ERR_INVALID_FILE;
+
+ QFile file;
+- file.setFileName("patches.txt");
++ file.setFileName("/usr/share/uefitool/patches.txt");
+
+ if (!file.open(QFile::ReadOnly | QFile::Text))
+ return ERR_INVALID_FILE;