summarylogtreecommitdiffstats
path: root/unreal-engine-4.sh
diff options
context:
space:
mode:
authorNeko-san2023-06-23 13:43:19 -0500
committerNeko-san2023-06-23 13:43:19 -0500
commit4cdf6d1f4db672d38ec4b8bc241b959dee0c45c5 (patch)
tree88032acdf22de250eabe6cc5b09400e5574776f3 /unreal-engine-4.sh
parentea73cbd0f6f20d92e9c367a8924a69d5ae61b568 (diff)
downloadaur-4cdf6d1f4db672d38ec4b8bc241b959dee0c45c5.tar.gz
Added a clarifying comment in the bash file
Diffstat (limited to 'unreal-engine-4.sh')
-rwxr-xr-xunreal-engine-4.sh12
1 files changed, 10 insertions, 2 deletions
diff --git a/unreal-engine-4.sh b/unreal-engine-4.sh
index 6c127fca307f..0433bd646975 100755
--- a/unreal-engine-4.sh
+++ b/unreal-engine-4.sh
@@ -1,15 +1,23 @@
#! /usr/bin/bash
+## I keep getting this question/comment, so I'll explain the reason for this here for those who feel compelled to ask again:
+# This file mainly exists to stop stubborn people who have a bad habit of running everything as root and to make sure specific paths exists to avoid arbitrary legacy compatibility issues.
+# It also assists with determining user-chosen custom install locations and ensuring the path to the editor binary path isn't entirely lost in the event 'UnrealEdior' is ever relocated to somewhere else for any arbitrary reason upstream decides.
+# If someone really wants to run Unreal with unmitigated admin privileges, any resulting damage is on YOU and not me.
+# You can still find the binary or modify this script/PKGBUILD yourself.
+# I am *not* going to troubleshoot short-sighted and insecure 'root everything' nonsense.
+# Additionally, I will remind you that "/opt" *is used by default* but the option is, again, ultimately up to the you where the installation resides.
+
if [ "$(id -u)" -eq 0 ]; then
echo "ERROR: Run this as an unprivileged user; not as root."
return;
fi
-if [ -d "${HOME}/.steampath" ] && [ ! -L "${HOME}/.steam/bin" ]; then
+if [ -d "${HOME}/.steam" ] && [ ! -L "${HOME}/.steam/bin" ]; then
ln -s "${HOME}/.steampath" "${HOME}/.steam/bin"
elif [ ! -d "${HOME}/.steampath" ] && [ ! -L "${HOME}/.steam/bin" ]; then
mkdir -p "${HOME}/.steam/bin"
- ln -s "${HOME}/.steampath" "${HOME}/.steam/bin"
+ ln -s "${HOME}/.steam" "${HOME}/.steam/bin"
fi
if [ ! -d "${HOME}/.config/Epic/UnrealEngine/4.27/Intermediate/" ]; then