summarylogtreecommitdiffstats
path: root/update-ffmpeg.install
diff options
context:
space:
mode:
authorFeakster2021-02-18 14:42:33 +0000
committerFeakster2021-02-18 14:42:33 +0000
commite4da6135d603100323c59a64d14551d091fff281 (patch)
tree4222dd0234494d3cadd045513adf6a23c674c352 /update-ffmpeg.install
parentcd22cbd62412ae5271dbf0ed7a25f17b07dcd1f2 (diff)
downloadaur-e4da6135d603100323c59a64d14551d091fff281.tar.gz
Cosmetic changes
- Altered some comments in the PKGBUILD. - Restructured the .install file to make it a little more robust to people manually digging around and removing files.
Diffstat (limited to 'update-ffmpeg.install')
-rw-r--r--update-ffmpeg.install16
1 files changed, 9 insertions, 7 deletions
diff --git a/update-ffmpeg.install b/update-ffmpeg.install
index 5cad48207065..b7f32091813d 100644
--- a/update-ffmpeg.install
+++ b/update-ffmpeg.install
@@ -8,24 +8,26 @@ _nc='\033[0m' # No colour.
### Post Install ###
post_install() {
## Install ffmpeg ##
- echo -e "${_yellow}Installing proprietary media codecs ...${_nc}"
- cd /opt/$_pkgname
- ./update-ffmpeg
+ if [ -f /opt/$_pkgname/update-ffmpeg ]; then
+ echo -e "${_yellow}Installing proprietary media codecs ...${_nc}"
+ /opt/$_pkgname/update-ffmpeg
+ fi
}
### Post Upgrade ###
post_upgrade() {
## Update ffmpeg ##
- echo -e "${_yellow}Updating proprietary media codecs ...${_nc}"
- cd /opt/$_pkgname
- ./update-ffmpeg
+ if [ -f /opt/$_pkgname/update-ffmpeg ]; then
+ echo -e "${_yellow}Updating proprietary media codecs ...${_nc}"
+ /opt/$_pkgname/update-ffmpeg
+ fi
}
### Post Remove ###
post_remove() {
## Remove ffmpeg ##
- echo -e "${_yellow}Removing proprietary media codecs ...${_nc}"
if [ -d /var/opt/$_pkgname ]; then
+ echo -e "${_yellow}Removing proprietary media codecs ...${_nc}"
rm -rf /var/opt/$_pkgname
fi
}