summarylogtreecommitdiffstats
path: root/update-version.sh
diff options
context:
space:
mode:
authorJames Bulmer2019-06-18 10:35:22 +0100
committerJames Bulmer2019-06-18 10:35:22 +0100
commit3e4bb76fd5325ddf91282df911f95ca04c953d27 (patch)
tree038079664de9b98fde6ea214194808ba53ceef7c /update-version.sh
parentca3bc843ab35dd7b7c8b0299b3ba9b364a1e7dc9 (diff)
downloadaur-3e4bb76fd5325ddf91282df911f95ca04c953d27.tar.gz
updating to version 13.8.0
Diffstat (limited to 'update-version.sh')
-rwxr-xr-xupdate-version.sh13
1 files changed, 13 insertions, 0 deletions
diff --git a/update-version.sh b/update-version.sh
new file mode 100755
index 000000000000..593667676ffe
--- /dev/null
+++ b/update-version.sh
@@ -0,0 +1,13 @@
+#!/bin/sh
+#
+# Update the PKGBUILD with the lastest release
+
+VERSION=`curl -fsSL https://get.please.build/latest_version`
+SHA256URL="https://get.please.build/linux_amd64/${VERSION}/please_${VERSION}.tar.gz.sha256"
+
+SHA256SUM=`curl -fsSL ${SHA256URL} | cut -d ' ' -f1`
+
+sed -i -e "s/pkgver=.*/pkgver=${VERSION}/" PKGBUILD
+sed -i -e "s/sha256sums_x86_64=.*/sha256sums_x86_64=(\"${SHA256SUM}\")/" PKGBUILD
+
+git commit -m "Updating to ${VERSION}" ./PKGBUILD