summarylogtreecommitdiffstats
path: root/update.sh
diff options
context:
space:
mode:
authorBloodyAltair2019-03-27 21:31:29 +0300
committerBloodyAltair2019-03-27 21:31:29 +0300
commit2738ef85f737d660eb76dbbbd6d2a09eec66985c (patch)
treea6f04105c118ba1693950214eea5ad9cb44fa2f0 /update.sh
parent5d1d80f0a78bfb1b7442d1817d12b915a8027c0b (diff)
downloadaur-2738ef85f737d660eb76dbbbd6d2a09eec66985c.tar.gz
+ Update scripts
+ Version update fix + Version update
Diffstat (limited to 'update.sh')
-rwxr-xr-xupdate.sh8
1 files changed, 8 insertions, 0 deletions
diff --git a/update.sh b/update.sh
index 00896230d655..3f224f90240f 100755
--- a/update.sh
+++ b/update.sh
@@ -1,9 +1,17 @@
#!/bin/bash
+
+# ##########################
+# You can use this script
+# to update PKGBUILD version
+# ##########################
+
+
_remote=$(curl -sL https://product-details.mozilla.org/1.0/firefox_versions.json | jq -r '.FIREFOX_NIGHTLY')
_current=$(grep _version= PKGBUILD | cut -f2 -d'=')
echo "PKGBUILD: ${_current}, REMOTE: ${_remote}"
if [ "${_remote}" != "${_current}" ]; then
sed -i "s/_version=.*/_version=${_remote}/" PKGBUILD
+ sed -i "s/pkgver=.*/pkgver=${_remote}/" PKGBUILD
echo "Updated"
exit 0
fi