summarylogtreecommitdiffstats
path: root/update.sh
diff options
context:
space:
mode:
authorzan2020-06-13 22:28:54 -0400
committerzanny2020-06-13 22:37:56 -0400
commitcd426c5228f6d9bf2a0c470871674125c9afaa8a (patch)
treec4c4bd1710573324b6b8daeb69737f7429c13cc8 /update.sh
parent9ef097251d355c139048a8397e4a8a555e299ad7 (diff)
downloadaur-cd426c5228f6d9bf2a0c470871674125c9afaa8a.tar.gz
21.5.0.0
Diffstat (limited to 'update.sh')
-rwxr-xr-xupdate.sh3
1 files changed, 1 insertions, 2 deletions
diff --git a/update.sh b/update.sh
index 641996a14967..20e6986152da 100755
--- a/update.sh
+++ b/update.sh
@@ -5,7 +5,7 @@ set -e
name="ODAFileConverter_QT5_lnxX64_7.2dll.deb"
dest="/tmp/$name"
-wget -N "https://download.opendesign.com/guestfiles/ODAFileConverter/$name" -P "$dest"
+wget -N "https://download.opendesign.com/guestfiles/ODAFileConverter/$name" -P "/tmp/"
new=( $(sha256sum "$dest") )
old=$(grep -oP "sha256sums=\('\K[[:alnum:]]{64}(?=')" PKGBUILD)
@@ -14,7 +14,6 @@ if [ "$new" = "$old" ]; then
exit 0
fi
-
ver=$(ar p "$dest" control.tar.xz | tar xJO ./control | grep -oP "Version: \K.+$")
sed -Ei "s/pkgver=[0-9\.]+/pkgver=$ver/
s/sha256sums=\('[[:alnum:]]{64}/sha256sums=\('$new/" PKGBUILD