summarylogtreecommitdiffstats
path: root/update.sh
diff options
context:
space:
mode:
authorSumner Evans2020-02-01 20:20:28 -0700
committerSumner Evans2020-02-01 20:20:28 -0700
commit2234f90659860162ac0b5fbaf34b98f7def2006f (patch)
treef68e3605d2f2f0d6c11a5d4a100f92912d2eee02 /update.sh
parent675d04e5ebff3eaa2ceaa0ec03f0652df1df6813 (diff)
downloadaur-2234f90659860162ac0b5fbaf34b98f7def2006f.tar.gz
v0.8.10 -> v0.8.11
Diffstat (limited to 'update.sh')
-rwxr-xr-xupdate.sh21
1 files changed, 4 insertions, 17 deletions
diff --git a/update.sh b/update.sh
index dd7854d66b88..fe1d75f0b139 100755
--- a/update.sh
+++ b/update.sh
@@ -5,7 +5,6 @@ PROJ_NAME=sublime-music
DESCRIPTION="A native Subsonic/Airsonic/*sonic client for Linux. Build using Python and GTK+."
URL=https://gitlab.com/sumner/sublime-music
DEPENDS=(
- pygobject-devel
python-bottle
python-dateutil
python-deepdiff
@@ -18,6 +17,8 @@ DEPENDS=(
python-pychromecast
python-requests
python-yaml
+ libnm-glib
+ libnotify
)
LICENSE='GPL3'
ADDITIONAL=
@@ -33,7 +34,7 @@ fi
SRCS=(
https://files.pythonhosted.org/packages/source/${PROJ_NAME:0:1}/${PROJ_NAME}/${PROJ_NAME}-$1.tar.gz
- https://gitlab.com/sumner/sublime-music/-/archive/master/sublime-music-master.tar.gz
+ https://gitlab.com/sumner/sublime-music/-/jobs/artifacts/v$1/download?job=build_logo
)
printf '' > PKGBUILD
@@ -74,17 +75,8 @@ md5sums=()
${ADDITIONAL}
build() {
- pushd \${srcdir}
-
- pushd \"\${_module}-\${pkgver}\"
+ cd \"\${srcdir}/\${_module}-\${pkgver}\"
python setup.py build
- popd
-
- pushd sublime-music-master/docs/logo
- make
- popd
-
- popd
}
package() {
@@ -94,10 +86,6 @@ package() {
python setup.py install --root=\"\${pkgdir}\" --optimize=1 --skip-build
popd
- pushd sublime-music-master
-
- ls -lah
-
desktop-file-install --dir=\${pkgdir}/usr/share/applications sublime-music.desktop
pushd docs/logo/build
@@ -114,7 +102,6 @@ package() {
install -Dm644 512x512.png \${pkgdir}/usr/share/icons/hicolor/512x512/apps/sublime-music.png
install -Dm644 1024x1024.png \${pkgdir}/usr/share/icons/hicolor/1024x1024/apps/sublime-music.png
popd
- popd
popd
}" >> PKGBUILD