summarylogtreecommitdiffstats
path: root/update.sh
diff options
context:
space:
mode:
authorMartchus2017-12-09 21:25:57 +0100
committerMartchus2017-12-09 21:25:57 +0100
commitf4e5c5e172406e6bb317d6186cac5d563a4368df (patch)
treedc18ca04ddf09c940ece937e520c0e6559ccb26e /update.sh
parent2a5c6508b1d1333ab6d4d91f806e91fdd3e260f6 (diff)
downloadaur-f4e5c5e172406e6bb317d6186cac5d563a4368df.tar.gz
Update to 4.0.0v20171209
Diffstat (limited to 'update.sh')
-rwxr-xr-xupdate.sh9
1 files changed, 8 insertions, 1 deletions
diff --git a/update.sh b/update.sh
index e897502e913f..9816f1d89514 100755
--- a/update.sh
+++ b/update.sh
@@ -19,7 +19,7 @@ srcfile=${BASH_REMATCH[2]}
msg2 "source file: $srcfile"
msg 'Split file name of latest nightly into components used in the PKGBUILD'
-compregex='vlc-(.*)-(.*)-(.*)-git.tar.xz'
+compregex='vlc-(.*)-(.*)-(.*)-(.*).tar.xz'
if ! [[ $srcfile =~ $compregex ]]; then
echo 'Unable to split source file into components used in PKGBUILD'
exit -1
@@ -27,9 +27,11 @@ fi
version=${BASH_REMATCH[1]}
date=${BASH_REMATCH[2]}
strange_number=${BASH_REMATCH[3]}
+suffix=${BASH_REMATCH[4]}
msg2 "version: $version"
msg2 "date: $date"
msg2 "strange number: $strange_number"
+msg2 "suffix: $suffix"
msg 'Update PKGBUILD'
mv 'PKGBUILD' 'PKGBUILD.bak'
@@ -38,6 +40,7 @@ awk \
-v _pkgver="_pkgver=${version}" \
-v _snapshot_="_snapshot_=${date}" \
-v _snapver_="_snapver_=${strange_number}" \
+ -v _suffix_="_suffix_=${suffix}" \
' /^[[:blank:]]*_pkgver=.*$/ {
print _pkgver
next
@@ -54,6 +57,10 @@ awk \
print _snapver_
next
}
+ /^[[:blank:]]*_suffix_=.*$/ {
+ print _suffix_
+ next
+ }
1
END {