aboutsummarylogtreecommitdiffstats
path: root/update
diff options
context:
space:
mode:
authorBen Alex2020-09-03 17:37:57 +1000
committerBen Alex2020-09-03 17:37:57 +1000
commit91b8566eb10e352eef426a88510ee5658ae14b56 (patch)
treeeafd3516cbb231aa401e9e9307c9372353216683 /update
parent4238e5a342fe6ae530e6fdd63f36037d288db040 (diff)
downloadaur-91b8566eb10e352eef426a88510ee5658ae14b56.tar.gz
update script to resolve symlink for latest version number
Diffstat (limited to 'update')
-rwxr-xr-xupdate3
1 files changed, 1 insertions, 2 deletions
diff --git a/update b/update
index 5bb3fd9a70ea..e9c8ffad10d7 100755
--- a/update
+++ b/update
@@ -30,8 +30,7 @@ if [ ! -e "$HOME/.tws_scripts/tws-latest-standalone-linux-x64.sh" ] ; then
exit 2
fi
-VER="`tws_get_version ${HOME}/.tws_scripts/tws-latest-standalone-linux-x64.sh`"
-if [ "$?" -eq 1 ]; then echo "tws_get_version failed"; exit 2; fi
+VER="$(readlink $HOME/.tws_scripts/tws-latest-standalone-linux-x64.sh | sed 's/.*-//g' | sed 's/.sh//g')"
grep -q "pkgver=${VER}" $SCRIPT_HOME/PKGBUILD
if [ "$?" -eq 0 ]; then