aboutsummarylogtreecommitdiffstats
path: root/update
diff options
context:
space:
mode:
authorBen Alex2021-07-31 12:19:58 +1000
committerBen Alex2021-07-31 12:19:58 +1000
commit9f1860e6b3935cb2b9214d2888b1561d764ebcad (patch)
treec9a65607b0d28b3dcd13dbac03677077d327ce96 /update
parentd084c27cfefef3fe9dd73660df8fd9b41dd7978e (diff)
downloadaur-9f1860e6b3935cb2b9214d2888b1561d764ebcad.tar.gz
Use sha256sum in update script
Diffstat (limited to 'update')
-rwxr-xr-xupdate2
1 files changed, 1 insertions, 1 deletions
diff --git a/update b/update
index 9ed1ee0a6252..b71a2dee413c 100755
--- a/update
+++ b/update
@@ -41,7 +41,7 @@ else
sed -i "s/pkgver=.*/pkgver=${VER}/" PKGBUILD
sed -i "s/pkgrel=.*/pkgrel=1/" PKGBUILD
# Next line from https://bugs.archlinux.org/task/15051
- { rm PKGBUILD; awk '$0 ~ /^md5sums/ {i = 1; system("makepkg -g 2>/dev/null")}; !i {print}; $0 ~ /\)/ {i = 0}' > PKGBUILD; } < PKGBUILD
+ { rm PKGBUILD; awk '$0 ~ /^sha256sums/ {i = 1; system("makepkg -g 2>/dev/null")}; !i {print}; $0 ~ /\)/ {i = 0}' > PKGBUILD; } < PKGBUILD
makepkg
if ! ls *.zst &> /dev/null ; then
echo "Package creation failure"