summarylogtreecommitdiffstats
path: root/update_version.sh
diff options
context:
space:
mode:
authorKnut Ahlers2021-04-15 11:09:04 +0200
committerKnut Ahlers2021-04-15 11:09:04 +0200
commit6cec5adc39f5250cea9427b262f6a4bde57fedbe (patch)
treece878a4d471b9704ce66153350acc21c86fc63b0 /update_version.sh
parentbb12b02c3e12a07ff300571086994b976c3622a3 (diff)
downloadaur-6cec5adc39f5250cea9427b262f6a4bde57fedbe.tar.gz
Fix: Update pkgrel only when version did change
Signed-off-by: Knut Ahlers <knut@ahlers.me>
Diffstat (limited to 'update_version.sh')
-rwxr-xr-xupdate_version.sh5
1 files changed, 4 insertions, 1 deletions
diff --git a/update_version.sh b/update_version.sh
index 2471f7792dd9..34106bf1c8b3 100755
--- a/update_version.sh
+++ b/update_version.sh
@@ -14,7 +14,6 @@ VER=$(curl -sSf https://dl.google.com/linux/chrome/deb/dists/stable/main/binary-
# Insert latest version into PKGBUILD and update hashes
sed -i \
-e "s/^pkgver=.*/pkgver=${VER}/" \
- -e 's/pkgrel=.*/pkgrel=1/' \
PKGBUILD
# Check whether this changed anything
@@ -23,6 +22,10 @@ if (git diff --exit-code PKGBUILD); then
exit 0
fi
+sed -i \
+ -e 's/pkgrel=.*/pkgrel=1/' \
+ PKGBUILD
+
updpkgsums
# Update .SRCINFO