summarylogtreecommitdiffstats
path: root/update_version.sh
diff options
context:
space:
mode:
authorKnut Ahlers2020-05-19 20:57:34 +0200
committerKnut Ahlers2020-05-19 20:58:01 +0200
commit289ba5a845937d9c7ba184977edf85c99b1d4043 (patch)
treeedb33e40964777267c57c63d7bbc47a27d0c2271 /update_version.sh
parent71b93bafd514ce5cefd96cf0836009c92d75eb70 (diff)
downloadaur-289ba5a845937d9c7ba184977edf85c99b1d4043.tar.gz
obs-v4l2sink v0.1.0 / obs-studio v25.0.8
Bugfix: Updater-Script missed to update checksums when updating the OBS version, this is now solved. Signed-off-by: Knut Ahlers <knut@ahlers.me>
Diffstat (limited to 'update_version.sh')
-rwxr-xr-xupdate_version.sh6
1 files changed, 3 insertions, 3 deletions
diff --git a/update_version.sh b/update_version.sh
index 90abb980a5e2..1d5ea7d78506 100755
--- a/update_version.sh
+++ b/update_version.sh
@@ -19,13 +19,11 @@ grep -q "^obsver=${obs_version}$" PKGBUILD || {
}
# In case there is a release, update the release version
-grep -q "^pkgver=${sink_version}$" PKGBUILD || {
+grep -q "^pkgver=${sink_version}$" PKGBUILD ||
sed -i \
-e "s/^pkgver=.*/pkgver=${sink_version}/" \
-e 's/pkgrel=.*/pkgrel=1/' \
PKGBUILD
- updpkgsums
-}
# Check whether this changed anything
if (git diff --exit-code PKGBUILD); then
@@ -33,6 +31,8 @@ if (git diff --exit-code PKGBUILD); then
exit 0
fi
+updpkgsums
+
# Update .SRCINFO
makepkg --printsrcinfo >.SRCINFO