summarylogtreecommitdiffstats
path: root/update_version.sh
diff options
context:
space:
mode:
authorKnut Ahlers2019-09-27 15:57:42 +0200
committerKnut Ahlers2019-09-27 16:01:20 +0200
commit2123e019276b357798521cb93c6ae0c5174dc052 (patch)
tree967013868fd0639db9ad828b0730d6af5b528f65 /update_version.sh
parent4a4eafad6ea6723a3740bf116b9b576c99f7890f (diff)
downloadaur-2123e019276b357798521cb93c6ae0c5174dc052.tar.gz
Move to develop branch
Signed-off-by: Knut Ahlers <knut@ahlers.me>
Diffstat (limited to 'update_version.sh')
-rwxr-xr-xupdate_version.sh9
1 files changed, 8 insertions, 1 deletions
diff --git a/update_version.sh b/update_version.sh
index 771446254fc6..53ce38ea6580 100755
--- a/update_version.sh
+++ b/update_version.sh
@@ -15,12 +15,19 @@ git clone ${REPO} ${WORKDIR}
# Fetch version information
pushd ${WORKDIR}
-VER=$(FULL=1 bash contrib/semver/version.sh | sed 's/^v//')
+git checkout develop
+
+VER=$(git describe --tags --long --always)
+VER=${VER/-/.r}
+VER=${VER/-/.}
+
+COMMIT=$(git rev-parse HEAD)
# Replace version in PKGBUILD
popd
sed -i \
-e "s/^pkgver=.*$/pkgver=${VER}/" \
+ -e "s/^_commit=.*$/_commit=${COMMIT}/" \
PKGBUILD
# Check for real updates